Moved to new NAS, complete reinstall - unable to use Roon

New Roon subscriber so it wasn’t a big deal to do this but now it is because its wasting my time…

I got a new NAS. I was running Roon Core / DB on my old QNAP NAS for about a week to play around. I decided I would move ahead and was already expecting a new NAS to be delivered. I tried [many things] to set it up again, including fresh installs etc. I thought that’s ok, I didn’t need the old config. So I set it up fresh on my new NAS which is using the disks from my old NAS, so it has the same name and is basically the exact same thing.
I installed the Roon Core on the NAS SSD.
I installed a Mac client on my iMac

Running Roon on the Mac to connect to the core, which it sees, I either get:

‘you’re only authorized for 1 core’

or nothing when I exit the app and try again. Just the logo animation thing.

I have tried removing it from both devices (NAS and Mac), removing the app and Library files on the Mac; stopping and removing the Core on the NAS and then re-installing both.

This is getting old. I want a fresh install but somehow logging in to Roon when initially running it on the Mac rooins all that…
How can I start over with a Roon Core/DB on my NAS SSD and a Mac client? I am fine with it finding all the music again (which is stored on the RAID disks of the NAS)

The logo animation I get when I try to connect to the Core

You will need to disconnect the core first on your existing machine that was running Roon Core.
Removing the software et Al does not accomplish this.
Roon still thinks you are logged into that core.
Hit disconnect.

You still then have Roon running on the Mac but now not as Core.

Yeah that’s not totally my issue - the core was on NAS1 and now its on NAS2 but since I moved the disks from NAS1 to NAS2 they’re named the same thing and have the same IP and config. I’m not sure I can get my old NAS up to do this but I’m going to try it.

Ok, a bit of a convoluted process but here is what fixed it.

I could not accept taking all the disks out of my new NAS, populating them in the old NAS (along with screwing them into the brackets…screw that). Instead, I stopped the core server on the NAS, told the Mac client to set up a new core on the Mac. It then complained that I was authorized on my NAS and I clicked de-authorize and then canceled the rest of the setup. Then I restarted the server on the NAS. On my iPhone Roon app, I attempted to connect but it complained I was authorized for the Mac. I unauthorized the Mac from within the iPhone app and connected to the NAS core server and it worked. On the Mac, I completely de-installed Roon (including the files in Library) and reinstalled it - then connected it to the Core on the NAS and it worked.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.