Moving from windows to linux - can't see NAA device

Hi there,

I am moving from windows 10 to linux mint, a dual boot on the same machine. I set up HQ Player this afternoon (delighted it is on Linux) however I can’t see my NAA endpoint. I have jumped back to the windows 10 login and the NAA is there and I can play to it.

In windows I run NordVPN and have HQ Player whitelisted in the app. In Linux, I have the whole subnet whitelisted. I have also tried turning the VPN off in linux but I still can’t see the device.

I am sure I am missing something obvious. How can I see my NAA in Linux Mint? Any thoughts @jussi_laako.

I believe I am on the latest versions of all the software.


Firewall could be blocking incoming response messages from the NAA. Or it could be that multicasts are not routed correctly to your local network but instead going somewhere else. Please keep in mind that multicasts are not destined to local network addresses, but instead to the multicast addresses.

If I turn the firewall and VPN off, I can see the NAA, but the weird thing is I still can’t get it to play. With either the firewall or the VPN on, I lose the NAA. So a number of issues to sort.

I have added a firewall rule, two actually (one in from the NAA and one out to the NAA), and with the VPN off, I can see the NAA. So that is one issue solved I think.

I need to work on the vpn, the whole local subnet is whitelisted, so I am not sure why I can’t see the NAA when the VPN is on. So this is still to solve. I wonder if I can whitelist the specific IP???

Finally, even when I see the NAA, I still can’t get anything to play, I have copied my windows settings across, but I intend to simplify and work my way up. So, this is still to solve too.

I am not sure I understand, could you elaborate please @jussi_laako? Thanks.

I have double checked all the settings; with the firewall off, I can see the NAA no problem but I cannot get anything to play. When I try I get this message in Roon, “starting playback of audio device, this may take a moment” but then nothing happens.

I have noticed this message in HQ Player “#clreadaudio::clReadAudio(): unsupported engine type”.

Other endpoint are playing no problem, just to rule out an issue with the core. I have restarted the Core and the rpi4 the NAA sits on.

Anybody got any ideas?

Any errors in HQPlayer log when you try to play?

Please check that you have input backend disabled if you are not using it for something.