MQA decoding processing speed

When I play MQA on my Bluesound node 2 it shows the processing speed in the UI signal path. However when I play the same stream to my Naim Atom it shows nothing. As the node 2 performs the final unfold to 192/24 and they both use Roon for the first unfold how come one shows the processing speed and the other doesn’t? I though this speed was how fast Roon was performing the action. So this because the Bluesound is fully MQA and the Atom only gets the first unfold and had no renderer. Just seems odd to me.

Perhaps because the first case entails more processing: Roon is performing the first stage MQA unfold and restoring the MQA signaling data for the second stage MQA rendering. In the second case, Roon is performing only the first stage MQA unfold.


1 Like

Thanks Andrew that makes sense I thought it would be the hardware taking that part but obviously not.

Processing Speed only displays when its under 100

Not sure I get what you mean @wizardofoz i’d like to a cpu that can do processing that high. The processing speed is an indicator of how fast its processing it compared to realtime…

Roon decided to not display processing speeds above 100 x as processing speed really only becomes an issue when it drops below about x 1.4

I found this thread as curious to understand why processing speed appears in my signal path when playing Tidal MQA to my Vitus MQA DAC.

So as I understand it, because Roon does not use pass-through audio, it has to rebuild the MQA/PCM stream as it decompresses the FLAC feed, and the extra CPU load takes the speed below 100x on some Cores, and hence it shows in the signal path?

Does this mean that in my device setup, the option to enable MQA Core Decoder is redundant, as Roon is going to rebuild the stream anyway if it knows the endpoint is MQA-capable?

The above raises some questions about whether there could be a SQ difference if I use my DAC’s own control point, in which case the Tidal MQA FLAC is processed entirely within the endpoint hardware.

I still noticed processing speed drop even when my DAC’s doing the whole decode and render. Which I found odd. The overhead must be in the software authentication I guess? Just one way doesnt allow for DSP without destroying the MQA data.

I use my DAC to do all the MQA processing but even with that the MQA authentication impacts the processing speed. For ordinary WAV and FLAC files the processing speed is over 100 but with MQA files the authentication alone brings the processing speed down to around 60.

when I play MQA from Tidal to one of my Linn streamers, with Roon doing the core decoding, there is no processing speed shown in my signal path, so the authentication and first unfold do not drop below 100x, but playing to an MQA endpoint does. I guess the latter is more intensive.

1 Like

Shouldn’t really make any difference, as its the same process is going on to the Linn.There are many things that affect Roons processing speed, network being one of them and likely the endpoint itself as Linn don’t use RAAT, perhaps RAAT is heavier on the network? I have had times where I have not seen any processing speed and times when there is.

My brother runs a Naim NDX2 off the same model of NUC as my Roon Core, and like Linn, the NDX2 is not MQA capable, but unlike the Linn, it does use RAAT. There is no reference to processing speed in his signal path when decoding MQA on the Core, just like I see with my Linn endpoints, so it seems the processing speed is only indicated for MQA endpoints. I’m puzzled by that, as I thought that either way, all the MQA data was put back into the stream no matter what. So curious as to why the processing speed is affected.

HI folks
I am testing a couple of MQA DACs, Topping D90 and SMSL SU9
Both devices are shown in Roon as “Decoder and Renderer” and for both of them I turned the MQA Core decoder off.
With these premises, I was expecting 0 work from the Core, but I still get a processing speed message at around 55/60x
Do you know why?
I thought MQA DACs were doing all the work…
ale still the authentication process which seems to be quite heavy for some reason.

Processing speed is only shown in the signal path when there is a level of processing being undertaken that is a load on the CPU core.
If the workload is able to be undertaken with no loading, there is no processing power figure displayed.
So when I unfold MQA in my Roon Core, running on a NUC based ROCK server, there is no processing power identified.

Yes, the NDX2 is Roon Ready, but I thought that Linn streamers were too. For a mate I set up his Linn steamer for Roon. It took a firmware upgrade on the Linn, and then it worked with a ROCK server I setup in his network.

I am using a NUC bases ROCK server as well, but I still get the processing speed.
The processor is an I3 Gen7, maybe a more powerful one like I7 would not show any processing speed

What processor are you using on your ROCK?

I am using a NUC5i3