Mqa files seem to default to 48khz where everything else plays at 192khz

I have a Rotel rc 1570 and a Mac mini from late 2012 plugged in via USB and I’ve been having some trouble making it sound as good as I feel it’s capable. As I mentioned in the title, I’m having issues with MQA files streaming at 48khz, but everything else plays at 192khz.

If anyone knows how to optimize sound quality from this equipment, please let me know.

Thank you,

Also, my device is nowhere to be found when I try to identify it in settings.

I don’t think your Rotel is a Roon Tested device so Roon will not recognize it. Get on to Rotel to send one to Roon and they will add it. Check out this link to find out more.

https://roonlabs.com/partners

Look at this to see about setting things up for MQA. I don’t think your Rotel supports MQA but Roon should do the first unfold for you and that will give you 96/24.

Can you post a screen shot of your Signal Path, and the Device Audio setup pages. That will help support see what you are seeing. It sounds like Roon is not doing the first decode step.