MQA will not work in Tidal/Roon combo

Hi all - I have three MQA capable devices on my network. Through their various proprietary apps (or through the Tidal desktop app) I’m able to pass MQA files to them for decoding and rendering without fuss.
I’m also able to pass locally stored MQA files via Roon to each device without an issue.
The problem only manifests (and manifests in all three devices) when I try to play MQA files via the Roon/Tidal combo.

In settings, the ability to switch on “Exclusive Mode” is absent on all of the devices. No idea why and no idea how to change it, but I suspect Roon defaults to exclusive mode on these and removes the option, so I don’t think that’s the cause.

For completeness sake, the devices are:
Moon Neo Ace (connected via wired ethernet)
NAD D3045 (connected via USB to PC)
Bluesound Pulse Flex 2i stereo pair (wireless)

Any ideas?

Have you got the correct version of Tidal selected. Hi Fi… ?

Hi Chris, thanks for the reply. Not sure what you mean though? I have “Masters” selected in the Tidal app, which is able to output MQA to the NAD, for instance. But in Roon it doesn’t have any Tidal settings, just the ability to login to my account. (For what it’s worth, the albums are showing with the MQA logo in my Roon library, but when I play back it’s just showing as 16bit/44khz flac with Tidal as the source)

Time to flag @support here for proper assistance.

1 Like

Hi Whilst waiting for @support to contact you…

Can you post a screenshot of that album and also a screenshot of Roon’s signal path when playing tracks from it.

Also in the zone’s device settings can you post a shot of how the devices MQA capabilities has been configured.


Here’s the NAD screenshot - you can see the MQA file listed just beneath the album cover, but the signal path shows the source as being 16bit FLAC

Device setup details in the next two screenshots…

Next up you can see a local MQA file outputting perfectly with the same device as the endpoint - all in order

Moon Neo Ace with the local file outputting MQA without a hitch…

Here’s a shot of the Moon and the Talking Heads file - same issue as with the NAD. (I’ve obviously tried this with several MQA tracks/albums)

Moon device setup…

Hope that’s all you require. I can also take photos of the two devices with their MQA logos lit up when I output to them via either the Tidal app (for the NAD) or via the Simaudio application via Tidal (for the Moon Ace) if that’s required (so that you can see that my Tidal app/account is working fine for MQA outside of Roon)

Your setup / config all look good to me .
The signal path is always correct, so on face value I say the Talking Heads album is not (or is not being streamed) as MQA, a false positive.
However, you say you have tried different MQA albums [from Tidal] and have the same issue with them, that to me at least, suggests a problem with the way Tidal is streaming them to you …

One thing to try … in Roon logout of Tidal and then log back in … this might force the Tidal servers to “resync to your account” stream to you correctly.

I’m out of ideas now … perhaps another example or two of Tidal MQA albums (together with signal path) that are not streaming in MQA might help @support track this down for you.

1 Like

I have just played this album on my system (from Tidal via Roon) and in my case the album is streamed correctly as an MQA encoded album. The issue as far as I can see is not related to the source album on Tidal.

1 Like

Well I’ve been playing around a little and things are a bit bizarre

I couldn’t get anything at all to play in MQA via the Roon/Tidal combo, so I logged out, completely shut the server down, rebooted, the full works.
Then just to check something, I logged in using my partner’s Tidal account and selected a random MQA track and it immediately lit up with the MQA sign.

So I logged back out and in again with my own login - same problem when using my MQA favourites. However, when I backed up and selected a random Tidal master for an artist I don’t even know, it worked. Back into my library and the Tidal masters saved in there simply will not play as MQA. Extremely bizarre.

I’m going to try and delete, then add everything back again using Roon instead of Tidal to see if that works. Even if it does work, though, it’s a poor user experience.
I wonder what could be causing it?

edit: and now I’ve gone back in, it won’t random MQA albums again, even random ones not in my favourites/collection. Truly strange!

Hi @JayKay,

I’d like to propose a test here that should give us some insight into what you’re seeing here.

  • Select System Output of your Core or a remote as the endpoint
  • Select an MQA album in your library that is not working correctly for you
  • Start playback of that album and note the time you start playback and the track that is playing
  • Take a screenshot of the Signal Path during this time
  • Get a screenshot of the File Tags of the track you’re playing (select the 3 dots option button, select view file info, and click File Tags in the upper right — This must be done with an album that is in your library)

Once you’ve done this respond her with the track you played, the time you started playback, and the screenshots requested, and I can enable diagnostics so we can take a closer look.



Hi Dylan

Happy to do this, but I don’t really know what you mean by your first point. How do I select System Output or a remote as the endpoint?

I’ve been experimenting and it turns out that every single one of the MQA files that won’t play is 48Khz source, while every single one that will play is 44.1Khz. Something weird is up with the way 48Khz files are being seen by my system (as I say, these files work fine if I don’t use Roon)

Will keep messing about to see if I can figure out what’s wrong


Yep, definitely only an issue with 48kHz source files. These files all play perfectly if I use the Tidal app or the manufacturer’s app, so it doesn’t seem to be an issue with the device compatibility. There’s something in my underlying settings that is forcing Roon to see 48kHz MQA files on Tidal as 16bit/44.1kHz files.
Even if I get Roon to do the MQA processing, it’s still seeing it as 16/44.1

I’ve tested with downloaded 48kHz sample files through Roon into these devices and it’s not resulting in the same issue - MQA is handed over without fuss to the Moon, the Bluesound and the NAD. As soon as I switch back to the Roon/Tidal/48kHz combo we’re back to CD quality. Not the end of the world, especially as I can access the files easily enough via the various apps, but I prefer to use Roon for obvious reasons.

I might flatten/reinstall Roon from scratch

Hi @JayKay,

You can do this by going to Settings | Audio in Roon.

For an album that isn’t playing MQA as expected, can you navigate to the Versions tab and confirm that there isn’t an MQA version listed in the other versions? Based on the previous screenshot you shared of the Signal Path, it looks like you are not playing the MQA version of the album

But if you navigate to the Versions tab and select an MQA version here, does that work?

1 Like

Hi Dylan

Yeah, I have checked that over and over and over again.
I can’t find any albums that are 48kHz MQA with no other versions (they all seem to have a 16/44.1 version somewhere in the background) but I’m definitely, 100%, without doubt, adding and playing the MQA version, just not receiving it when it’s output.

As I say, this happens with EVERY SINGLE 48kHz MQA file on Tidal, and yet somehow with every single 44.1kHz MQA album it works perfectly. It’s as linear as that - all 44.1kHz MQA files will play. All 48kHz ones will not. And this remains true regardless of which of the three MQA capable players I select as the output (and also if I try to switch the decoding/rendering to software instead of hardware)

Anyway, as per your request (at 19:08 BST):

Just as a matter of course - here’s a totally randomly selected album with a 44.1kHz MQA source - no settings have been changed but you can see the MQA file appearing happily in the path

I can upload countless examples of both 44.1kHz working and 48kHz not working if you need me to, but as you mentioned you’d like to narrow things down to one album, I’ll leave that one for you

Hi @JayKay,

Thanks for the information here. Diagnostics have been enabled and the team is currently analyzing the report. In the meantime, they were hoping you could once more use the other TIDAL account that did work and play this exact same track. Can you confirm that MQA works fine? Can you share screenshots like you did above when using that account?

Hi Dylan, thanks for your help so far. With regard to Tidal - it’s the same account, just a family one, so different login on the same account, but I’m having the exact same problem with that too. 44.1kHz MQA files play perfectly, 48kHz ones don’t.
As mentioned, when I use the Tidal app, I don’t have the same problem, so there’s something weird going on in the Roon/Tidal interface @ 48kHz that doesn’t seem to be a problem @ 44.1kHz. I’m not tech-savvy enough to even guess why, nor whether that sounds strange or entirely plausible, but that’s what I’m seeing

Hi @JayKay,

Thanks for confirming that it is not account specific. The diagnostics report is with the technical team now — I’ll be sure to let you know when I receive their feedback.

1 Like

Hi @JayKay,

If you restart your Core machine and try again, is there any change here?

Hi @dylan - I’ve restarted it several times but no luck. In fact in the last couple of days, all MQA has stopped working via Roon/Tidal if the album/file is in my library (I can confirm that it continues to work fine via Tidal app)

I’ve restarted the Core (it’s headless) and the access machine several times, plus I’ve tried using remotes on iOS, Android and Amazon Kindle - none of which make any difference.

Really bizarre one. I’ve kinda accepted that it just isn’t going to work for me, because I flattened and reinstalled and it’s made no difference - I still only had 44.1kHz MQA working. As mentioned, even that now no longer works on albums in my library (if I select a random MQA 44.1kHz source file on Tidal via Roon it will work, a random 48kHz file will not)

I really have no idea what’s going on :joy:

Spoke too soon - now random 44.1kHz MQAs have also stopped working, so MQA is totally dead via Roon/Tidal for me
I wonder if it’s an issue with Tidal? Although that should mean the Tidal app wouldn’t work, I would guess. Just throwing out random ideas because I’m totally stumped