Much (much) more than the advertised '5 minute setup'

Hi All

I’m having a torrid time with Ropiee and after 24 hours, still don’t have a working Roon endpoint. Ultimately, my problem is that the boot sequence hangs here not for the promised ‘sec’ but actually several hours;

Additionally, when it does eventually fully boot, the device does not appear in Roon.

Here’s what I’ve done and experienced so far…

Downloaded the Ropiee image, etched it to an 8GB card and booted my RasPi 3B with HiFiBerry Digi+ Pro

I have an HDMI screen attached so can see the boot and install process. The Pi is on a wired ethernet connection. My network is perfectly fine for all other devices (Unifi infrastructure with approx. 40 desktop, mobile, tablet and IoT devices)

Ropiee did its thing, installed itself, updated itself etc. (stage 2)

Pi rebooted into stage 3 and took a long time to proceed (stuck at above screen). I put this down to initial config. The green light continues to blink rapidly.

Eventually, light blinks slowly, HDMI blanks and I can access ropiee.local from my iPad.

The UI is very sluggish, slow loading the tabs etc. I set my HAT config etc. and this forces a reboot. Again, we get stuck at Stage 3 for several hours (I gave up and left it overnight)

Today, I find it eventually booted and I could access ropiee.local. Again, it’s really sluggish, takes 10s of seconds to load up tabs etc.

I fired up a Roon client, but could not find the Ropiee in settings. I’ve tried this with both Roon 1,7 and 1.8 as I updated my Roon to see if it made a difference.

I rebooted my Pi once more (after restarting Roon server), but it’s again stuck at Stage 3 after successfully finding NTP service.

What gives? This is virtually unusable, and does not appear as an endpoint in any case.

Anything else I can try???

Can you send me feedback?
You can find that on the ‘advanced’ tab of the webpage.


1 Like

I will, as soon as I get past this. Could be tomorrow :frowning:

The behavior you are experiencing is not normal, and usually points to another problem in the chain (SD card, networking, Pi itself). I am not convinced that the HDMI screen is giving you any useful information, because it is disabled after boot after installation.

You asked for other things to try:

  • Use the IP instead of the name for UI access. Verify that there isn’t any arp craziness in your network.
  • Format the SD card and try again
  • Try a different OS, like DietPi, as a test
1 Like

Many thanks.

I guessed this would not be normal.

Once the device boots up again (still waiting), I’ll try IP access (I need to send the feedback anyway).

I was running HiFiBerryOS on the device and that seemed to be performing OK (although it was giving me only shairplay access to the roon endpoint, which is why I wanted to try RoPiee in the first place).

The HDMI link is giving me insight to the bootup process. Yes, its disabled once it loads, and thats working fine. They problem I have it it’s stuck in this stage 3 booting state for an eternity (relatively speaking!)

I do have another identical Pi and some other cards, so I’ll try all that as well, to rule variables out.

As noted, I don’t believe I have any networking problems as I know it well and run multiple devices and appliances, but yor suggestion is good as I usually use IPs generally.

That is extremely weird.

Let’s wait for the feedback.

Feedback sent. Reference is 02c34919c0b5044b

I tried with direct IP access, and while occasionally pages seemed to load faster, And I’ve had three or four clicks in a row that could be termed ‘normal’, I’ve also had runs that were same as before with >5 second delays.

The device still doesn’t appear in a Roon despite restarting everything.

I’ll spend some time tomorrow troubleshooting with alternative Pi’s, cards etc.

The reason it is not showing up in Roon is because RoonBridge is not installed.
It is trying to correct that upon start-up, but the Roon download server times out.
That also explains the long waiting time, because it tries that 5 times (which times out every single time).

This could either be on your side, but I suspect this might be related to the troubles Roon is having these past days with their infrastructure.

Can you just restart? (pull the plug) And try again?



Great to know.

I’ll nuke everything and start again. I’ll also try with different devices and cards as discussed earlier if it doesn’t work out.

Can you share the download link that’s and command that’s being attempted? (wget over ftp, http etc.) I could try it from another machine on the network to rule out any infrastructure issues.

No need to try different devices and cards. I assume this is not related to the hardware but just a network issue.

wget -t 2 -T 30 -O /tmp/



I could download that and the bin file referenced inside it just fine via browser and/or CURL from other machines on the network.

I’ll try a few things like moving th Pi to a different network socket etc. to start ruling out possible issues.

Good news, thanks to @spockfish and clarity around the stall, I was able to narrow down the issue to a bad network cable.

Roon now playing through Ropiee. Thanks all!