Multi disc opera identified as two identical compositions

… one with disc 1 and the other with discs 2 and 3. I’ve tried renumbering tracks and discs to no avail. Artists (a lot) field is exactly the same in all tracks. Am I overlooking something? How can I fix this? Also having trouble with merging compositions or one specific opera. Is there a way round this?

Have you tried “merging” the albums. You don’t say. You also don’t say if the album titles are the same. For example. All three album titles must be “Some Album Title” instead of “Some Album Title CD1”, “Some Album Title CD2”, “Some Album Title CD3”, or “Bonus Disc” or similar.

As long as the album titles are the same and the disc numbers are unique the you should end up with one album after merging. Now whether the album is identified or not, that is another story.

… yes, I’ve done all that, and the crazy thing is that the three discs are shown as one album. Only under compositions it is shown separately…

Ah! That happens to me as well. This is what I do.

  1. Go to your directory (outside roon) in your OS. Move the folder somewhere that roon is not looking. I am on windows so I just move it to the desktop. Roon then removes it from your library.
  2. Make sure disk numbers, track numbers, album titles are what they should be in an external tagger (I use mp3tag on windows, many on mac use Yate).
  3. In roon go to “settings / library / clean up library / clean up xx deleted files”.
  4. Copy back your album to your watched roon folder.

Should be ok now.

I think roon gets confused if you import an album with poor metadata and you try and fix it all in roon. Sometimes it works. Sometimes you just have to start over again.

… ah, this trick works perfectly! Many thanks for this!!!