Multi-User Computer [solved]

I am working in a Mac environment and am having problems with multiple user accounts on the same computer. My Mac Pro is humming away as the Roon server and we have a shared Macbook Air. I can set up the portable as an end point but when I tried launching under my wife’s account I get an error - attached.

Help! :wink:

I forgot to say that I set up the end point under my account

Sounds like a file permission error. You could try changing access to all users to the RoonServer folder.

If that’s does not work we will have to get @Mike to take a look for you.

Not sure, but if the software configuration is my account’s preferences rather than the system’s then that is a design issue…

I tend to agree … I’ve never been happy with Roon and even more so with RoonServer installing in the user account space.

I feel that’s area for improvement but I suspect it’s way down in the priority list.

In the means time, I’ve been considering creating a Roon user account on my Windows setup just to hold the RoonServer install.

Unfortunately, on a Mac, to open up the user home directory to other users will break the security model of the file system. This will be similar under Linux as well. You have to grant read permission all the way down the file system tree which might have unintended visibility given to the other users. Not so important for my wife and me, but if the kids were still in the house…

I’ve run into this sort of problem in the past with software written initially for Windows. Windows developers like to install things into the user space, bypassing O/S security. Mac (BSD Unix) and Linux require shared items to be installed into the system space (such as /usr/lib and /usr/bin on Unix or /Library/preferences on the Mac). User configurations then should be in the home directory of each user.

Another issue is that non-Windows system are more often used in a multi-user space. Locks and resources need to managed accordingly.

Not relevant to this issue is properly implementing multi-user licensing. A lot of software is licensed per computer but implemented per user account.

No one is asking you to do that. Run Roon as yourself, and let Roon write to your own home directory. On Mac, we write a tiny lockfile to your home dir, and then write quite a bit to ~/Library/Roon/. Users running the app should have permissions to write to their own directory. This is pretty common UNIX behavior. You are failing because you can’t write to your own home dir.

chmod u+rwx $HOME; chown `whoami` $HOME

Roon is meant to run locally per user, and not system wide. If you want to force Roon into system wide install, you might be able to succeed with looser permissions, but I wouldn’t recommend it.

If you install Roon into a shared location and run as a different user than who owns the file, you will break self-updating, but nothing else. Also, our dev team is split about 50/50 on Mac vs Windows.

That’s why we write to your user’s home directory, and not to some global directory.

All licensing is done based on your Roon account + machine identity, and nothing to do with software install.

It’s working properly now, not certain what that lock file business was. Perhaps two accounts were logged in at once?

Maybe someone could clear this up for me, as I’m having the same issue. Is there a fix in the above thread? Perhaps the ‘chmod’ line?

RoonServer is running on a headless Mac Mini. I can control via an iMac27 as well as my account on a MacBook Pro. But, if I try to run Roon on my wife’s account on the MacBook Pro, I get the Lock File error. Not a big deal, but I’d like to clean it up.


Roon is designed to be run on a per-user basis, so if you and your wife are both going to use Roon on the Macbook Pro, the best bet is probably to each install separately.

If your wife is having problems launching Roon, there may be some permissions problems, that can be solved by following the steps here.

1 Like

Thanks, Mike. I’ll give that a try…


Okay, this is a bit odd, but with the installation of Build 88 and working with HQP, this issue was pushed to the back burner for me.

It used to be that of the two accounts on a Macbook Pro (mine and my wife’s), my ‘side’ could run Roon Remote, but her side generated the lock file error.

Now, somehow, things are reversed. I can run Roon from her account, but now I’m generating the lock file error.

Issuing the command in Terminal that you referenced above does not change the result. I still get the lock file error.

Not a huge deal in the overall scheme of things. Just stamping out the little fires…

We actually found a bug here the other day :blush:

There lock file issue should be resolved for our next release, sorry about that!



Whoop-whoop! Good going…

Like I say, it’s no big deal, but it’ll be nice to sign in from anywhere in the house – no matter the user account – and gain control of the server.

Merry Christmas to you and the team. You’re doing a great job with this.