Multichannel files via Nucleus+ HDMI output to an A/V Receiver

Roon Core Machine

Nucleus+ (build 1021) with internal storage Samsung SSD 2TB

Networking Gear & Setup Details

Fritzbox 6591 Cable, Ethernet

Connected Audio Devices

A/V Processor McIntosh MX122, HDMI connection
5.1 Speaker setup (Left, Center, Right, Right Surround, Left Surround, SW)

Number of Tracks in Library

45,000 tracks

Description of Issue

Hi,
Have already read a lot on this in the forum, I guess I still need some help on the topic “Multichannel files via Nucleus+ HDMI output to an A/V Receiver”.
My setup:
-Roon core: Nucleus+ (build 1021) with internal storage Samsung SSD 2TB
-A/V Processor McIntosh MX122
-5.1 Speaker setup (Left, Center, Right, Right Surround, Left Surround, SW)
The Nucleus+ is connected by HDMI to the McIntosh.
Multichannel music files (FLAC, DSD) stored on the Nucleus+ internal storage and identified by Roon correctly as 5.1 audio files.
Nucleus HDMI A output is set to Channel Layout “5.1”, Multichannel Mixing Strategy is “downmix as needed” (changing this to “7.1” and / or “Channel Mapping Only" doesn’t solve the described issue below).
The FLAC files are “untouched” by Roon, the DSD files are converted to PCM by Roon.

Observations (with FLAC and DSD files):
-playing multichannel via the selected Nucleus HDMI A output in Roon seem to give mixed channels to the McIntosh. Typically the left rear speaker is not audible, looks like this speaker receives the LFE signal.
-the other speakers seem to get wrong signals as well, e.g. right speaker gets signal for right surround speaker.
As a crosscheck I put some multichannel files on an USB stick, played them with my Oppo 205 Player via HDMI to the McIntosh and everything is correct.

As the mixed channels are difficult to identify with music files, I downloaded a short channel mapping wav file with spoken channel identification (spoken is: “left”-“center”-“right”-“right surround”, “left surround” and an LFE test tone).
Playing this from the Oppo 205 everything’s fine, the spoken channels and the LFE test tone coming out of the correct speakers.
Playing this from the internal storage via Nucleus HDMI it’s completely mixed:
-spoken “left” comes from right speaker
-spoken “center” not audible
-spoken “right” comes from center speaker
-spoken “right surround” comes from right speaker
-spoken “left surround” comes from right surround speaker
-LFE test tone comes from left surround speaker.

I tried to change the channel mapping in Roon with the DSP Procedural Equalizer and the mix tool, but without being able to map the channels to the correct speaker.

So to cut a long story short, I still have no clue how to fix this issue :blush:
Thanks in advance for your support,
Manfred