Multipart tracks, pt2[Solved]

This is not really an issue / error, I’m just trying to find how Roon works with multipart tracks.
I positively hate multipart tracks. I like playing random tracks for a genre, artist, mood, period or combination (for instance: ‘pop 1974’). Now when Roon encounters an album that is registered as multitrack I get to hear up to 12 tracks from one single album. In the random playlist these tracks are all seen as parts of one single track.
There is nothing I can see that would allow me to unlink these tracks. It is not in the track name.
for instance the tracks on:

look like:

There is no M3U, no artist name or album name embedded in the track name, no indicator whatsoever that links these tracks that I can see.
When I toggle the composition / parts grouping, nothing seems to happen:

Where can I find that magic switch?

If you go into Edit Album, the last setting down will toggle between tracks and whole works.

As you can see I switched to ‘prefer file data’ (this is the last setting down) then did a force rescan.
This is the result:


So: nothing changed.

Oh boy, this is a biggie. 2 weeks in since the latest comment and no response. Who rises to the challenge?

Let’s see if getting the topic to Support will generate more exposure

Hi Egbert,

The new version 1.4 now has a Disable Multi-Part Compositions on this Album. In Album View, click 3 dots menu and select Edit. Under the Edit Album tab, you’ll find it at the bottom.

Cheers, Greg

1 Like

I just noticed, and came back here to see if anyone else had!
It does the trick. Marvelous!.
Case closed.

1 Like