Multiple problems with latest builds

Core Machine (Operating system/System info/Roon build number)

NUC8i3BEH (1.7 610) with internal ssd, ethernet to router.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Cable modem and Linksys router with Ethernet connections. Wifi with iPad Pro remote connection.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Yamaha r-n803d amp, Topping d10 connected with usb to NUC and coax to amp or Airplay directly to amp. iPad Pro 11 2018 remote.

Description Of Issue

I Started using Roon in January and it worked very well before this summer but unfortunately recently there have been problems every day when using it. I think these started during last 2 updates.

  • Red icon in Roon with message: “Metadata Improver: Halted. Roon needs a software update.” Even if I have been using latest software for days.
  • When NUC Rock is started, it sometimes takes minutes to log in to Tidal.
  • If not logged to Tidal, search does not work and overview takes time.
  • Often, after using Roon some time, Tidal albums are not shown. Only those that I have in my collection are shown and can be played. Tidal page opens but shows text “Failed to load items”. Tidal playlists and other info is shown. NUC needs to be rebooted to get albums appear again.
  • Adding Tidal album has not worked correctly at least since last update. Adding album does not end, info shows for example: 50 tracks, 50 added, 0 indentified. Couple times when album was added cover is not correct.
  • Tidal app in iPad works always even if there are Tidal problems in Roon.
  • Lastly, one old issue that is happening more often (many times a day). iPad app needs to be force quit because it does not work correctly (hangs or shows just blank screen with album playing info at the bottom.)

Nothing has changed in my setup during this time. Latest updates installed and NUC rebooted regularly

Hi @ds_2, Welcome to the Roon forum, sorry to see you’re having issues, I’ll try to add a little info to help:

I suspect the Tidal login issue causes most of your remaining issues. Roon reaches out to Tidal for searches and an overview. Adding Tidal albums will also fail if there’s a connection issue. If there is some kind of network blocking on your core (as suggested by the Metadata improver issue) that might also cause the Tidal issue?

Finally, depending on your tech know-how and bravery, this link Synology Linux Roon Server cache delete might also help (remove cache contents). For extra reference the contents of my cache directory (NUC with Debian an RoonServer) looks like this:

ls /var/roon/RoonServer/Cache/  httpcache_2.db  httpcache.db  qobuz  qobuz_1.db  sessions  smc.db  tidal_2.db

I hope some of this is useful.

Thank you for information @killdozer,

Work pc uses Vpn but is not even connected to same router. I tested this and when I disabled Vpn and booted Rock, Roon was able to complete album addition and metadata message was removed. But maybe this was just coincident, because…

Even with Vpn disabled there has been many Tidal problems and iPad lockouts.

And Tidal albums added do not get cover art, only general picture is used. This never happened before latest update.

Dare you brave the cache? :wink:

Hi @ds_2,

Welcome to the forum!

Based on your symptoms and this issue being intermittent, I would start off by checking your DNS servers on your router, it is possible that some DNS lookup requests are failing.

If you are using the ISP-default DNS servers we instead would suggest using Cloudflare DNS, Quad9 or Google DNS.

Can you please give this a try and let us know if it helps?

I have cable modem and wifi router connected to that. Devices are connected to wifi router with cables. What do I need to check and from which one? Cable modem shows 2 DNS addresses but no error log or anything like that.

Everything worked for months and there has been no changes to my network during this time.

Have you restarted all the network gear modem router etc

@killdozer, brave yes :grinning: and know how to but I want to treat Nuc Rock as non-computer as possible and prefer to wait little for other solutions.

@wizardofoz, thank you for looking at this. Yes I have restarted cable modem and router many times.

Hi @ds_2,

Are you running ROCK on the NUC?
If so, can you please share a screenshot of your ROCK’s Web UI?

What DNS servers are configured? Can you please share a screenshot of this?
Are you using the latest router firmware?

Yes, Rock on Nuc. Latest firmware on router. I think DNS servers are managed by ISP. Using DCHP, gateway and dns address are same.

For addional info, I checked logs (below) regarding missing album art (address and album name hidden and marked as xx). If I enter album address in web browser it is shown correctly.
Warn: Error in web request xx NetworkError (The request was aborted: The request was canceled.)
Warn: [additionalimages] networkerror downloading album cover for xx Result[Status=NetworkError, ErrorText=The request was aborted: The request was canceled.]

No changes in my network setup and Tidal worked before.

Also I have tried logging out and in to Tidal and tried frequent boots on Rock and network gear. But still Tidal problems described In opening post remain.

Hi @ds_2,

Please share the bottom part of this page:

I am interested in the info under the Networking section, which is currently hidden. Thanks!

In addition to Tidal errors there are many web request/network errors in log file, like:
Warn: our service credentials are out of date: update is needed.
Warn: Halting identifier: invalid credentials
Debug: [identification] status: Halted
error accounts/login
error accounts/machineallocate
Failed to refresh account info

Hi @ds_2,

Thanks for that screenshot, this does look like a valid DNS address.

As for next steps, can I please kindly ask you to use these instructions to access your Roon Core logs (Method 1) and send me a set?

If you have any issues accessing logs or don’t have file transfer services, just let me know.

Thank you noris,

I do not have file sharing like dropbox, so how can I send you logs securely (as they contain sensitive personal information)?

Hey @ds_2,

I’ve followed up via private message!

Already answered couple times to private message and do not know if I should also answer here.

Any news on this one (logs were uploaded last week)? All problems (that started during latest updates) are still present:
Tidal albums (those not in my collection) are not shown.
Tidal albums are not synced correctly.
Album covers are not fetched.
Metadata warning.

Tidal albums that are in my collection can be played. Tidal app always works. And nothing have changed in my network. First 6 months worked very good and now Tidal does not.

1 Like

Hi @ds_2,

Thanks for sending those logs over and for your patience while I had a chance to review.
I looked over logs and I believe you have a networking issue somewhere along the line,I’m seeing issues with you authenticating with our account servers and constanst Network errors when trying to download album covers:

	Line 26801: 09/03 15:49:41 Warn: [additionalimages] networkerror downloading album cover for 166:0:18644039: Result[Status=NetworkError, ErrorText=The request was aborted: The request was canceled.]
	Line 26844: 09/03 15:51:11 Warn: Error in web request NetworkError (The request was aborted: The request was canceled.)

This is interesting, which browser did you use to open the image, the iPad?

If you have another PC, it would be good to confirm if these issues are just impacting the NUC or other Cores on the same network:

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Hi @noris,

Thank you for checking this. I tested album art address with Chrome on my w10 laptop.

As you suggested, I tried Core on that laptop and everything works correctly. Tidal synced correctly and all artist and album info/art was fetched. Tested 3 hours without any issues.

Laptop is connected over wlan to same router as NUC Rock. NUC is connected with ethernet.

So this should not be network issue in my end because nothing have changed. Only change was ROCK updates and after those Tidal became unusable. I hope there is something to get ROCK working again.

Any news on this one?