Music files not being recognised

Roon Core Machine

Roon server runs on a windows 10 i7-7700T CPU @ 2.90GHz with 16GB RAM

Networking Gear & Setup Details

PC connected to network via Ethernet switch
Music stored on QNAP NAS TS451+ with 8GB RAM, also connected to same switch

Connected Audio Devices

Music played on Devialet Pro220, LS50W and Klipsch Three wireless speaker

Number of Tracks in Library

Over 40K+

Description of Issue

I had over 50K tracks, QNAP was attacked by QLocker ransomware. I have managed to recover around 40K+, however, when I ‘force rescan’ on Roon, it only shows 25K-26K tracks.

Do you have “show hidden files” enabled in settings:general?
Also are any of these files wma?

This doesn’t sound like a successful recovery to me. Did you contact QNAP support after the attack as recommended by QNAP so they can help you?

Dear TheHammer,

Yes, to both questions. The files I am not seeing include MP3 and FLAC as well

The recovery was from music stored on a separate drive. I did contact QNAP and their support team assisted with recovery of photos. For music I just took the data I had separately

1 Like

Are any files skipped? See Settings > Library > Skipped files.

Hi Martin, thanks for pointing this out, I am seeing just 62 music files and another 44jpg/tiff files as corrupt.

This does not seem to explain the gap. I am not sure how else to scan.

Have you tried playing any of the “missing” files using a different music player?

I tried to play using VLC and these are indeed corrupted files, so unplayable. But again the number of such files is very low, compared to what i was expecting to find

I suspect you have many files that Roon simply can’t open. You could use FLAC Frontend to test your media files for errors.

Okay, will this software also be able to create / find a list of FLAC files
in my library?

I use the flac command line tool on Linux, and this can list all files with errors. The Windows frontend can do this too, but I’ve never used it.

Edit: This is what I’d do it Linux (should work on a Mac too.)

find . -type f -iname '*.flac' -print0 | xargs --null flac -wst

still no luck, the files work on flac frontend, but not recognised on Roon

So, you had zero errors when running the test? If so, there must be another reason Roon hasn’t loaded the files. Can you confirm your storage locations are correct under Settings > Storage?

Dear Martin, I confirm storage settings are correct and the correct folder is mapped

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.