Music folder local path issues


last week I splurged out and bought a SSD for running ununtu and Roon database on as well as 2TB hard disk for music.

As my old harddisk with roon server was 100% filled. I installed a new Ubuntu on the SSD and then installed Roon.
Managed to transfer the roon database to the new SSD.

But then I felt like a total newbie, I can not manage to add my library on the 2nd disk (2T harddisk) as a watched folder.
Tried with local path /dev/sdb1/My_Music but cannot see my collection.

I am also no longer able to see the harddisk with music form my windows machine…
Still trying to figure out how to get SAMBA running for that disk.

Any help will be much appreciated!

you need to mount the drive in Linux in order to be able to access it. How’s it formatted - NTFS or ext4?

Once mounted you need to add that mountpoint to your samba share.

I can see the disk on my Ubuntu desktop but it has no name except a long range of numbers and letters.

Ubuntu is auto mounting it, hence the string. I don’t use Ubuntu, so here’s a little guessing, but right click on the drive icon and unmount it.

Open a terminal and type the following:

sudo mkdir /mnt/ntfs lsblk

you should see something similar to:

/dev/sdb1: UUID="a14c3308-fb3a-4c6c-b5b2-19fc5a126488"

Copy the string inside UUID="" – it’s the universal identifier for the drive

now run:

sudo nano /etc/fstab

add a line for your NTFS drive

UUID=PASTE_UUID_STRING_HERE  /mnt/NTFS  ntfs-3g  defaults,windows_names,locale=en_US.utf8  0 0

Save changes and reprocess fstab file:

sudo mount -a

You can now point Roon to local folder /mnt/NTFS

Next time you boot the drive should automatically mount.

GUI instructions are here:

Thank you for the info.
Sorry to say that did not work for me. Got errors and now Ubuntu is no longer starting up :-(((

the mkdir /mnt/ntfs did not work.

the command for ifnding the uuid is lsbik
The long UUID is the partition UUID

Now I have to find a way to bring Ubuntu alive again by getting to the fstab and the deleting the entry I made

Plug a monitor and keyboard into the Ubuntu machine and reboot it. There’ll be an option to login to terminal - once you’ve done that open /etc/fstab as above and put a # in front of the line referencing the NTFS drive. Save and reboot then we can check where you made an error in the mount string.

Thanks Evan,

I was lazy and reinstalled Ubuntu.
Then did a proper edit of etc/fstab with nano.
Checked it worked before going on.
Was a bit of a learning curve for me, obviously I do not work enough with Linux.