Music Import from WD NAS is not working

Hi, I hope you can help me.
I am just starting with Roon (fascinated) but face a severe problem.

Roon Core is running on my iMAC 3,4 GHz i5 32 GB
My music files are located on a WD NAS (My Cloud EX2 Ultra).

When I import files from the first folder (about 2.000 HD Musik Files) everything went OK.
But when I start to import files from the second folder (about 50.000 Music Files) the import stops around 6.000 imported files.
The Roon app that crashes and I have to restart my MAC, to get the app back working (can’t start it after it crashed).
But with the restart, the app start to import from the NAS again and crashes again.

Here are the file paths that I use.

Any Ideas?
Do I have to buy another NAS?



First, I don’t think you need to buy another NAS.

Strange behaviour on import could stem from some special cases with certain files or directories (names, special characters) - usually @support is able to help after having a look into the log files. I’m sure somebody from the support team will pick up on this soon. :slight_smile:

Hi @Stefan_Janssen,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Next I’d to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Hi Dylan,

thanks for helping me.

I use a router from Deutsche Telekom (Speedport W724V)
Next is a DLink DGS 1210-48 Switch to which all my network cables are switched to.
I use four different NAS (Movies Music and Back up).
And I use 21 Sonos Zones.

I started the process of reading my music files around 6:50 p.a. and it did not continue at 6:58.
Now it shows the embedded picture.

Hope this helps you

Thanks Stefan

Hi @Stefan_Janssen,

We enabled diagnostics on your account and the diagnostics report came through. We reviewed this with the team and, based on what we’ve seen in the report, it appears that there may be a connectivity issue between the Core machine and your NAS.

We sometimes see this behavior with managed switches. As mentioned in our Knowledge Base, managed switches often require some advanced setup in order to work properly.

If you try connecting the Core machine and the NAS directly to the router, bypassing the switch, does the same behavior occur?

Dear Dylan,

thanks for the idea but I am unable to do so.
The core (my iMAC) is located on my second floor and the router (and the switch) are in the basement.
Any other idea?

Hi @Stefan_Janssen,

As mentioned in the article linked above, can you confirm that you have flow control enabled on the managed switch?

…sorry, but where do I find flow control? I am looking in the setup menu…
As I mentioned. I am far away of being professional with this things.

Hi @Stefan_Janssen,

This should be in the settings for the managed switch. If you’re unsure you can share some screenshots of the settings and we can help take a look.


Dear Dylan,

thanks. I found it and changed to Flow Control enable (it was disabled)
But now I am trying a different set up.
I connected the NAS as well as an other Mac (mini) via an unmanaged switch.
I configured the Mac mini as new core.
From what I can see now, it looks better.
But the integration of the song (55.000) looks to be very (!) slow (steady but slow).
So we will see tomorrow (due to the time zone I am living in).

Dear Dylan, the good news is, that it runs.
The bad news is, that it took like 6 Hours for around 5.000 tracks (of a total of 51.000) to be integrated in the Roon database.
So there is a lot to go.
Is this the regular speed (Mac mini 2,6 GHz Intel Core 15 8 GB 1600 MHz DDR3) or is something wrong with my system?
When I start to stream DSD Music to Sonos (OK while still running the scan process) I do have a lot of dropouts.
Is that getting better once the scanning process is done?

Thanks for helping me.

Yes, definitely. Scanning is actually doing file analysis for volume leveling etc, and it can take quite a bit of time depending upon the hardware, if the analysis is going across the network, etc.

One thing you can do, is to pause the analysis when you want to play music and then turn it on again when you are done with your music listening. This can be done under settings/library/Background Audio Analysis Speed. Set it to OFF to stop it (it will restart where it left off when you later turn it on again). Then later, when you are done listening turn it on using as many cores as the computer has to help speed things up.