Music in Roon has tones that are very 'sharp' and sounds like the Treble is very high

Roon Core Machine

Screenshot of System Info

I use the docker container of the RoonServer app

Networking Gear & Setup Details

  • I have my UnRaid server plugged into my router Sepectrum Wave 2 RAC2V1A Router via ethernet.

  • My Computer Windows 10, is plugged into the router via ethernet

Connected Audio Devices

Optical Wire → Schiit Asgard 3 Amp → Schiit Modius 2 DAC

Number of Tracks in Library


Description of Issue

The issue is that when I play music from my Tidal App (Not Roon, but Tidal desktop app), or any other app for this matter, the sound is fine. (Note: All EQ settings are turned off for all apps.)

When I play music from my Roon Desktop app, the sound hits very ‘high highs’ that sound sharp, and becomes painful to listen to. For example, if the song has a high note, the high note goes very high, and sounds sharp, metallic, and painful for my ears which gives me a headache quickly.

I have no EQ settings applied. See screenshot below:

I do not know the issue, because all EQ settings are disabled in Roon, so in theroy the sound should be identical in Roon as it is in all other apps which also have EQ turned off.

All other apps (also have EQ turned off), the music sounds ‘fine’. When played in Roon (EQ turned off), the music is very high-pitched and painful.

Hi can you post a screenshot of Roon’s signal path when you playing a track.

1 Like

So to get this straight. Core is running in a container on the UnRaid. The Windows PC is acting as streamer and remote?

Have you turned exclusive mode on in Roon’s audio settings for the DAC connected to the PC and it’s using the same driver and output as the other sources?

1 Like

Also I think its worth mentioning that I have WASPI Installed

Core is running in a container on the UnRaid. The Windows PC is acting as streamer and remote?

Yes Exactly <3

Have you turned exclusive mode on in Roon’s audio settings for the DAC connected to the PC and it’s using the same driver and output as the other sources?


After examining more due to your comment I discovered that Roon (slightly high pitched) was using a different sound output than the other software’s.

Sound Output devices:

  • Roon: Digital Audio S/PDIF (Note, It is not a Bifrost, it is an Asgard 3 with Modius DAC - there was no icon for Modius, so I selected Bifrost)

Now that I have toggled back and forth a few times, I am confused, there are times when the two options sound identical, and other times when i’m sure that the Digital Audio S/PDIF is causing me ear-aches because of the high pitched.

At times I think im imagining it… at other times I am sure it is high pitched.

Strangely, it sounds best on my iphone, which is a bummer because I thought the AMP and DAC would really improve it. The music is ‘stronger’ on my computer, but the music is more ‘well rounded’ on the iPhone and does not hurt my ears.

Questions for all:

1.) Could this be related to WASAPI?

2.) Is there a manual way I can use EQ to reduce the ‘high notes’ to make it sound more like my iPhone? (I know… yuck iPhone, i cannot believe I am saying that…)

3.) Are there any tests I can do? because I feel as if my ears deceive me a bit sometimes…

Thanks all


I replied to @CrystalGipsy with the screenshots, some thoughts and questions. I appreciate it!

Do you know what the difference between these two outputs?

  • OS Mixer
  • WASAPI Exclusive mode

I have WASAPI enabled… so in theory, should WASAPI also be impacting OS Mixer?


I have listened to my iPhone again and compared it to Roon and other software.

It appears that my iPhone is more ‘well-rounded’ sound compared to my computer. Does anyone know why?

The computer has WASAPI enabled, and no EQ. The music is ‘high-pitched’, while the iPhone sounds more mellow. The ‘higher-pitched’, is slightly ‘tin’ sounding and really hurts my brain and ears.

My Computer uses the amp:

  • Asgard 3 (no DAC)
  • Modius (No multi-bit)

Has anyone else had a similar issue? I am thinking that the issue is NOT a Roon issue, and is an issue with my AMP and / or the DAC.

What your likely hearing is the combination of a poor Spdif implementation on the pc and the DAC isn’t doing a great job of being able cleaning it up. PCs are not always the quietest electrically and can produce noise that can be sent on to more sensitive audio equipment such as a DAC. This can often present itself in the higher freq. Os mixer is just that the audio output is via the os audio path and is limited to what that does and cannot be guaranteed to be lossless as Roon has no exclusive access.

Roon Core Machine

M1 MacBook Air 8gb Ram

Networking Gear & Setup Details

MacBook is connected to a Wifi 6 TP Link EAP 620 Access Point. Access Point is connected via Ethernet to a Firewalla Gold. Firewalla Gold is connected via Ethernet to Hegel H120

Connected Audio Devices

The Hegel H120 is connected via Ethernet utilising Roon-Ready protocol.

Number of Tracks in Library

232 Albums, 741 Tracks 99% of which from Tidal Hifi Plus.

Description of Issue

Basically I ran into the same problem like Jeff from his post:

I noticed that I can’t stand loud music anymore. After listening critically I noticed that the very VERY high trebles were extremely over present. It is almost inaudible when you don’t pay close attention but emotionally you just can’t stand listening to your hifi gear anymore.

Before this happened I played with the DSP section like equalizer, headroom management, removed all filters and added PEQ back again etc. but I turned everything off again in the end but me playing around seemed to have caused this issue.

I have no clear reproducible way to cause this issue but it is definitely something going on in the DSP section because the solution to this problem was to click the gear Icon top right and to reset the entire DSP section. That fixed the issue.

So this is more an informative post since the mentioned post by Jeff is closed so I can’t offer that solution in that topic.