Music playback hangs

It would be cool if I could just share a system setup with you guys automatically through Roon instead of having to describe it in detail every time something is up.

Sonos’es on wifi, intel NUC running core connected via Ethernet. iPad to control.

Everything worked nicely but now suddenly playback hangs. App shows that it’s playing but it’s not. Can’t do anything from my iPad although app is not frozen but playback is. Can’t stop/start or change song. Super annoying to have problems when you want to hear music. I will restart the nuc. I also get these tidal login problems every now and then. Never with sonos.

Reliability is everything and sonos gives me that, Roon not so much. It’s close but I’d say 85% trouble free, sonos 99%. That’s my experience at least.

Hi @Mads ---- Thank you for the report and sharing your feedback with us.

Moving forward, to help me evaluate what could be causing this behavior to occur, may I very kindly ask you to please provide me with the following:

  • You mentioned, “NUC running core”. Are using ROCK ? A version of Linux? Windows?

  • Are you noticing this behavior with any other endpoints, or just with your Sonos devices?

  • Please confirm which Sonos devices you are currently implementing.

  • Are you using these devices as a group, as stand alone end points, or both?

  • You also confirmed that they are on Wifi. During your troubleshooting have you tried hardwiring any of the units directly to your router? If so what was the experience like?

  • In your report you mentioned that everything had been “working nicely”, has anything changed in regard to your setup since making this observation (i.e “music playback hangs”)?

  • Please verify where you musical library is being stored/accessed from.

  • Please describe your network configuration/topolgy as well as providing insight into any networking hardware that you may be implementing. I want to have a clear understanding of what the chain of communication looks like between your devices and the tools being used to make those connection possible.

-Eric

Ubuntu Linux. Latest version 17.2 or something? Running a play:1 and connect Sonos. Sometimes group sometimes standalone. Hardwiring of any sonos device would be solely for making Roon work and not an interesting option for me. The nuc needs Ethernet it seems and it has that. Using NAS and tidal. Whew.

Rebooted and it worked again.