Music playback is interrupted, lost connection to core

Roon Core Machine

cirrus7 nimbini
Intel NUC Comet Lake i5
SSD970 250 GB
Roon Rock installed (actualy version)

Networking Gear & Setup Details

Fritzbox 7590 direct ethernet connection to NUC

Connected Audio Devices

Bluesound Node2i with ethernet connection to Naim DAC
RME ADI-2 DAC via USB (temporary for headphones)

Number of Tracks in Library


Description of Issue

Since last Friday I’ve had irregular breaks in music playback. Sometimes after 10 minutes, sometimes after an hour. There were no changes to my system. I got the message that the metadata optimizer is paused.
I’ve rebooted the router and core multiple times. Unfortunately without success.
Thanks for support

I saw, that my Fritzbox 7590 on 27.01. updated to the new firmware 7.50. Exactly since that day the problems with roon started. can there be a connection?

The problem still exists. Metadata optimizer is paused, covers are not updated for newly added albums and playback stops after a short time. So I can’t do anything with roon. Does somebody has any idea?I installed the core on another computer, the same problem there. So it shouldn’t be the NUC.

Hi Mattes
That may be.

There seems to be a statement from AVM regarding 7.50 firmware:

<<The Mesh Home Network display in the FRITZ!OS version 7.50 requires more information from the devices operated in the Mesh network than in the previous firmware. Even devices that are connected to earlier Mesh versions via AVM products can no longer be displayed properly there.>>

So, are there any managed switches, WIFI repeaters, or powerline adapters you can try to remove from your setup?

What you can also try, the fritzbox allows you to go back to the previous firmware:

Or wait for @support if they can see something in the logs.

1 Like

Thank you. I will try this today.

… unfortunately it was not successful. Do I have to use the bluos app until there is a solution. Everything was well for 2 years, now that I’ve gone for “lifetime-rooner”, there are problems :frowning:

Unfortunately, I still can’t use roon because there are interruptions at irregular intervals (connections to the core disconnected). I saved the log file from the last disconnect, can I upload it somewhere so it can be checked?
So roon is useless for me…
Thanks for the support.

Too bad, there is no support from Roon. I haven’t been able to use Roon for 4 weeks, I regret my decision to make a lifetime subscription. Can this be undone?

Oh this very sad to hear.
@Suedkiez is an amazing allround supporter and might have an idea as long as there is no feedback from support / @metadata_support

1 Like

Roon support is working through the queues, they have too much work for a few people but will get to you. In the meantime, let’s check a few things, if only to rule out that they are the cause. The problems happening after the Fritzbox update may be a coincidence or it may be significant.

You have a quite similar system like I (cirrus7 Comet Lake i5, Fritzbox 6690 with 7.50).

@Axel_Lesch asked a very good question that you didn’t answer:

I would add, do you have Fritzbox mesh devices?

I had no problems going from FritzOS 7.29 to 7.50. However, there are some hidden settings on the Fritzbox that caused problems in the past. They are documented in the Roon networking help

I never had problems with the Fritzbox but looked into this a while ago out of interest. It turned out the names of the settings have changed since, and interestingly also that different Fritzboxes seem to have different defaults. (Maybe also differing between privately owned Fritzboxes and those that are rented from internet providers). There is a setting that could well be problematic but should usually off by default. Another one is usually on by default and I would very much recommend to keeping it on normally, because without it the Fritzbox performance drops dramatically; however, it might be worth trying if turning it off makes a difference.

Possibly the settings changed for you with the update to 7.50, so let’s check. My Fritzbox is running with English language so your UI might differ:

Log into the Fritzbox and go to Help and Info:

Scroll down and click Fritz!Box Support:

Scroll down and check the Packet Acceleration settings. Do you have the same options as I, “Layer 2 acceleration” and “Hardware acceleration”?

The defaults on my Fritzbox are as shown in the screenshot. These settings should normally not be changed - that’s why they are under the Fritz!Box Support section. If yours differ, post a screenshot please.

The meaning of the settings is as follows:

  • Layer 2 acceleration should be off. If it’s on it can speed up networking by doing tricky things, but doing so makes the Fritzbox not strictly follow networking standards (I spare you the details). Turning this on is (a) not necessary in a typical home setting and (b) what it does may indeed be problematic for applications like Roon that do a lot of network discovery and things like that
  • Hardware acceleration should normally be on. If it’s off, much of what the Fritzbox does runs in software instead of the hardware implementation. If I turn this off, my internet connection speed drops from 300 Mbps to 75 Mbps and wifi performance suffers heavily as well. In addition, I don’t see much potential for this having any bad effects (unless the hardware has bugs, but if it does, then the software may have bugs just as well.)

Turning off hardware acceleration might be an interesting test to turn this off to see if it helps, but let’s postpone this for now. First, please confirm if you have the same options with the same settings as I have or if yours differ

1 Like

Please rename the zip file to include your Community username, name, or your email address …

Better read the entire article!

Regarding the dropouts, I would try to factory reset the Bluesound node 2i. I have one myself and know that those units can be troublesome sometimes.
My node is hard wired to the router, not on wifi.
Since then everything is fine.

Good luck!

1 Like

Thank you for the feedback @Suedkiez.
I checked the settings in the FritzBox, the layer 2 acceleration was active, I deactivated it, see screenshot.

But there was no change.
I disconnected my bluesound node from the network (is connected to LAN) and only connected the NUC to the RME-ADI-2 via USB. Also removed the switch. I unplugged my Fritz repeater (Mesh). So I’m assuming it can’t be the node or the switch or repeater. Roon sometimes plays for 1 hour or more after first switching on and then loses connection to the core. After about 2-3 minutes, it’s connect automatically and I can press play again. Then the disconnections are more frequent.

Thank you for the feedback @axel_lesch.
the node is not connected via WiFi and even if I take the node completely off the network, I have the connection breaks.
I will now upload the logs as suggested by you.
Thanks very much.

OK, then I guess it’s not the cause and safe to turn it on again. Was worth a try :slight_smile:

Hello @Mattes_Lauenstein
there is still something you can try to resolve the issue, please read this article:

You have already tried some of these, but I would definitely try to disable IPv6 on your router and core if you haven’t already done so.

And also, try to change your DNS settings, please have a look:

If that doesn’t help either, you can try to reinstall the operating system and restart the roon server software from the web interface, here a pic of my own web ui:

All of these actions are risk-free and it may well be that everything works again afterwards.
(Don’t forget to reboot your router and core machine)

Hello @Axel_Lesch,
thank’s for the Tipps. I have already changed the DNS settings to Google. I can’t deactivate IPv6 because I don’t have internet anymore (or I’m not doing it right…). My Provider is 1&1.

I renewed the operating system and the Roon server software. Unfortunately no success.

Hi @Mattes_Lauenstein,

Thank you for your patience, as I know you’ve endured an extreme wait time for clarification and follow-up here.

We’ve pulled more recent diagnostic reports from your Core to investigate what might have been going on and whether the issue is recurring. There were a few notes/questions we wanted to pass along:

  1. Have you experienced recent dropouts with internet radio? Logs show an error associated with a known Live Radio bug that we hope to resolve soon.

  2. Diagnostics show a Macbook endpoint consistently dropouts on the network, and also indicate RAATServer frequently can’t access the network for key processes like device discovery. Do you have any other network hardware in play here, like a second router or managed switch? Do you have any other issues with audio streaming on your home network, like the Tidal/Qobuz native apps?

  3. As an interim step, let’s refresh RAATServer:

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon Database
  • Stop RoonServer from running in the ROCK’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the RoonServer in the WebUI to generate a new RAATServer

Hello Connor,
Thank you for your feedback. To your questions:

  1. I have crashes with Liveradio but also when playing albums from my library or Qobuz.
  2. Otherwise I have no problem in the network. Since it’s not fun to listen music with Roon at the moment, I use the bluOS app, which works perfectly. I don’t have a second router or managed switch.
  3. I have now reinstalled the system several times. It then works for 1-2 days, sometimes only 10 minutes, before the connection to the core is lost.
    In principle, I am very unhappy with the situation. Everything worked fine for 2 years, shortly after I bought the lifetime license, there were problems. I invested around €2000 together with the hardware and now I have an unreliable system and support that has left me hanging for 3 months. Sorry for the clear words but I am very dissatisfied.

I had a similar problem - the cause was a Lan switch that was broken. I was able to use all other devices (Naim NDX2) without any problems except roon. (despite defective switch)
After replacing the switch, the problem went away. In addition, I had also exchanged my router Netgear for a new model.
The error was already gone but my Lan switch exchange

Sorry my bad englisch