Music played well but unknown was displayed on the touch screen

Here is the log identifier. @spockfish


My setup is R Pi3 + iFi Micro iDSD

Check that the zone is spelled exactly the same in RoPieee web setup, and the extension is enabled in Roon settings.

Hi @Ke_Zhang ,

You do realise this is an open source project? And that’s something I do in my spare time?
I’m not a company where you bought a product and you can just shout out: “go fetch”.

Regards Harry


Hi @Ke_Zhang, I had the same issue and it was because I didn’t read the instructions properly. You have to go in to Roon and enable the RoPieee extension. Settings, Extension, enable RoPieee Remote Control. You then also need to make sure the end point is named on the RoPieee web page for your end point the same as it is in Roon. Then it all works as soon as you play something. If after you have tried these it still isn’t working we will try to assist as best we can.

@Nathan_Wilkes @Henry_McLeod

Thanks you guys information and you are right, I misunderstood the “Roon Control Zone” in ropieee’s display tab. I thought it is something for roon to control Ropieee node, but actually it is the zone/node being controlled by Ropieee. Now I followed your suggestion and it works perfectly.


Sorry about that. I was not intend to ask for any sort of instant response or support for my issue. Just because I found in other tickets the “feedback identifier” is kind of important and helpful information when people asking the Roieee’s question. I am not rush/push the question that I am having and just want to save your time and reply in case you want to look at that feedback log like in other tickets. Ropieee is a great project and I really appreciate your effort on it.

One more question for the “Roon Control Zone”, can this option specified on touch screen directly or the web interface is the only way to set it up?

Thanks you guys’ replies on my dumb question.

The zone is set in the web interface. Only settings exclusively related to the display are set in the options screen of the display.

ropieee is a great bridge!
I currently use pi4 and configure a 4.3" dsi display. It can display well and the touch function is normal.

Hifiberry digi+ pro is installed on my pi4, and I also plug in usb dac!
Usually I use hifiberry digi+pro to listen to the tracks…

But when I switch the output to usb_dac…, I have to re-enter ropiee web settings → display → roon control zone to display the tracks played by usb dac. This operation is a bit troublesome…

Can the display roon control zone fill in two zones at the same time? No need to manually enter the ropieee web settings?

No it can’t at the moment.