Music randomly stops

Core Machine (Operating system/System info/Roon build number)

Rock operating system v 1.0, server software 1.7

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Intel NUC i5 with music stored internally on a ssd. NUC is connected by ethernet cable.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos, Lumin d1, Chromecast.

Description Of Issue

Audio stops randomly. Usually after 30 sec to a minute I can press play and resume. The music looks like it’s playing with the bars moving next to the song. This happens no matter what audio device is used. I did a test and installed the server on a windows machine. Ran it for 3 hours without it stopping. Looks like the issue is with the NUC.

1 Like

Are you using two SSD in the ROCK NUC, one for boot, and one for music?

What are the brand / model / capacity of the two SSD?

Try playing music from internet (Tidal or Qobuz) instead of local music.

Try copying some different stereo music to a USB drive, and plug it into the NUC. Play the music from the USB drive, not from the internal SSD drive. You can find free music from:

The NUC has 1 SSD for booting and 1 SSD for storage. The storage drive is a 480GB Kingston SA400S3. It makes no difference if I am playing music local or streaming.

I have a my music backed up on a network drive and can play from there. Would this be as good as a testing with a USB? If not I will find a USB drive a play from it.

Thanks Ron

Please disconnect the NUC from the network. Power cycle the whole network, starting from the router, including any access points, switches, powerline adapters. Then reboot the NUC, Lumin, other endpoints, iPad, etc. Connect the NUC to a different port, using a different network cable if you have.

If you checked that Tidal or Qobuz behaves the same as music on the local 480GB SSD drive, we can rule out the drive being culprit. Please do the local network music play test, so as to reconfirm this.

You said the on screen bar is moving, just no audio is produced. When you encounter this, please look at the network LED at the Roon Core, as well as the LED for the network port at the switch that connects to the Roon Core. See if they still flash.

Hello @Ron_Breem, wklie has some great suggestions here! Please let us know the results and we’ll go from there.

I cycled the power as sugested and problem still exisit. Music stops on all of my audio devices. The chromcaste audio is WiFi and my Sonos and Lumin are wired. Just to eliminate most switches and wall receptacles, I moved both the NUC and the Lumin to the router and plug both directly in with new cables. The music still stops. There’s only one cable between the cable modem, which is bridged, to my router. I even tested that cable with a line tester.

I did all test streaming from TIDAL.

When I said the bars keep moving after the audio stops, I meant the EQ bars next to the song playing. The progress bar at the bottom stops. After about 20-30 sec the pause button turns to play and I can resume play. It will not resume unless I hit play. While listening to the Lumin and displaying to a chromecast video, the chromecast will disconnect.

After this started happening I had a problem with my router and replaced it, so the router should be the problem.

One other thing. When connecte to my Sonos, I get a message right after the music stops “Lost control of audio device”. I don’t see this with the chromecast or the Lumin.


Hello @Ron_Breem, what is the model number of your new router? Also, do you experience this when playing to system output of a remote?

Sorry meant the router shouldn’t be the problem. I was having the issue before I replaced it. The model is a
Asus RT-AX82U.

I tried playing from my tablet and it stopped playing in about 6 minutes. After waiting around 30 seconds I was able to press play.

I put Roon server on a Windows PC and its been playing for the past 20 hours. Over night on the Sonos and for the past 10 hours on the Lumin. I guess that mens the NUC is the problem. Any ideas why the NUC would be stopping? On occasion I’ve had to restart restart the Roon software in the browser, beacuse my tablet couldn’t connect to the core.

What is the brand and model of the boot SSD in the NUC?

XPG SX6000 lite, 256 GB

I suspect that we’re facing a NUC hardware failure of some sort.

If you have not tried using a different network cable to a different port of the switch (or router), try it.

If you have a faulty RAM, the Roon server should have crashed - but there’s no clear indication this is the case so far. If you like to confirm there has been no crash, you’d need to ask support to do log analysis for you.

RAM can be checked by running the free memtest software anyway.

If you have a problematic motherboard or power supply, it’d crash or completely hang and never recover.

You have already reproduced the problem from music outside the local storage SSD, so the 480GB SSD is not likely to be the cause.

So, if I were you I’d replace the 256GB boot SSD with the smallest capacity version of Samsung 970 and reinstall ROCK from scratch.

If you are not comfortable make a purchase without knowing it 100% solves the problem in advance, you could use a spare drive, even a HDD (just for diagnosis purpose), to reinstall ROCK. Or move the 480GB music somewhere else (e.g. NAS or another USB drive), and install ROCK there.

No matter what you do you’ll need to power down the NUC and disconnect the m.2 SSD first.

Yesterday I replaced the boot drive and it looks like the problem is resovled. I have been running 2 zones, Lumin and Sonos, continuously for 20 hours. Thank you for your help, I never would have guess the boot drive was the problem. Excellent customer support.


1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.