Music starts, stops and skips without warning

Roon Core Machine

Roon ROCK running on NUC8i7BEH with 128gb m.2 SSD and 16gb DDR ram

Networking Gear & Setup Details

Unifi Dream machine pro into 16 port powered Unifi switch with 3 separate Unifi wifi 6 pro access points.

The Roon Rock is directly connected to the 16 port switch. I have a 8 port Switch across the house that is connected via gigabit ethernet to the 16 port switch. The Nova is plugged into the 8 port switch.

Connected Audio Devices

Naim Audio Uniti Nova, Naim Muso QB2, Bluesound Node 2. The Naim Nova and Bluesound are connected via ethernet. The Muso QB is wifi with fixed IP.

Number of Tracks in Library

Tidal playlists for 95% of streaming.

Description of Issue

This is a new development over the past week. No changes to my home network and I’ve used Roon for years.

Anytime I try and play a song/playlist Roon will start a track play a few seconds then without error/warning the music stops or moves to next track and does same thing.

I’ve power cycled everything. Verified I have most recent Roon software. Tried just using 1 end point. Nothing seems to solve the problem. I also turned off the DSP I was using.

I believe I’ve isolated the problem to the Roon ROCK. I can use Naim Audio’s app to stream to the Nova and QB without issue. Same goes for using bluesound’s software for the node that is connected to a whole home system.

Any help would be appreciated. I’m sure what else I can do to troubleshoot the Roon ROCK.

@Jeremy_Hutchins, can you post a screenshot of your web admin page of your ROCK Core? Also, have you tried connecting the Core using a different cable or a different port either on the NUC or the Unifi switch to eliminate a faulty cable or connection?

Possible failing hardware? SSDs can fail. I don’t know how to check SSD health in your set-up.

Have you looked at the logs for anything interesting?

I have tried a different patch cable and a different port. No luck.

Not exactly sure what the web admin page is, but here is a PDF of what I think you are asking about.

Sorry quality sucks on picture. Used my phone to take picture of the page and i use OLED TV as PC monitor.

If that is not what you need could you please point me in the right direction?

Thank you for the help!

Regarding the request for logs.

I opened up file explorer (windows 10) and went to my network trying to find \ROCK\Data. Windows can’t find it. Maybe that’s the problem? Doesn’t show up in network devices, but shows up under Unifi interface as connected and I can still connect to the ROCK from my phone, PC and Mac.


I assume you typed \\ROCK\data and the forums ate the second \? The double \\ at the beginning is required.

Since you know the IP address of your Core try:


where aaa.bbb.ccc.ddd is the address of your core like \\\data

The fact \\rock didn’t work shouldn’t impact any core functionality it just means windows couldn’t resolve “rock” to a machine on your network. But that kind of resolution is only used to find this network share.

I went to ip.address\data using my PC, which is on same ethernet and I get a HTTP error 404.

I can still type the ip address into chrome and reach the admin page.


I use the ROCK as a core as mentioned above, but cannot access logs using the network IP and/or search. I can however pull up Roon Logs from windows data. Not sure if helpful. The file is in txt. I converted to PDF but not allowed to upload. Is there a way to upload the txt file?

It’s not HTTP it’s SMB

Click Windows → run

If you’re on windows.

Found a trouble shooting guide ROON had posted. I didn’t have SMB enabled in “windows features.”

I have since enabeled the feature and I can see ROCK under network devices but still cannot access data. If I try to use windows file explores I get a pop up “Windows cannot access \ROCK”

If I use chrome and type in the \.iaddress\data I get “your file couldn’t be accessed.”

But I can still get to admin splash page. Should I nuke the whole thing and “reinstall” software or “reset” Roon Database and Settings?

As it is now that software is not useable.

Hey @Jeremy_Hutchins,

Thanks for taking the time to write in, and for your patience while the support team works through each thread.

Following up here, I’d be curious to see how things run on a fresh database. But before doing that, I’d like to enable diagnostics on your account to review what might be happening at the time of your audio drop outs /skips.

If you could please provide the specific date, time, and name of track the next time you reproduce this issue, that would be helpful. :pray:

I’ll be monitoring this thread for your reply.

Using the admin web interface I logged in and restarted the Roon Server Software. Ever since I did that I haven’t had any streaming issues.

I’ll let you know if it happens again with the details you requested.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.