Music Stops after 2-5 minutes following 1.8 update

Core Machine (Operating system/System info/Roon build number)

QNAP TS-453 Pro ( / 8GB RAM, J1900 CPU, 4x4TB RAID5 / Roon Build 756

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Draytek Vigor 2860
3x Pro Signal CAT6a Patch Panel
3x Ubiquiti US-24-250 (aggregated)
3x Ubiquiti US-8-60
8x Ubiquiti UAP AC Pro
CAT6a throughout

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Meridian 218, Meridian MS600, Meridian MS200, Innuos Zen Mini 3

Meridian Explorer 2 (via HTPC)
Meridian Explorer 2 (via iPad Pro)

There’s a few more but these are used daily.

Description Of Issue

We have been using Roon happily on our network since it was first released.

Since updating to 1.8 Roon has been unusable on any device.

As it stands, you can play 2-5min and then the audio will cut out. We have tried Tidal, Radio, local CD content, local low-res MP3. Nothing will play for more than a couple of minutes.

Moreover, the audio zone often disappears when the audio stops, and you have to re-select it.

I have noticed that even with zero zones playing (because they can’t), and with no remotes connected, the Roon process on our QNAP is ‘sleeping’ at 50% with regular jumps to 90%.
I imagine the spikes to 90% might be when it drops out but I haven’t been able to confirm this.

I can’t imagine why that would be the case when it has been running fine for 5+ years.
If this is Roon gathering metadata, is there any way to confirm that this is what it’s doing? Why would it cripple the system when it didn’t before?

We have gone to great lengths to ensure that our network is as sound as can be, or at least as far as we understand how.
Cross-network data transfers (e.g. PC to PC) achieve the expected speeds and are tested regularly.
Nothing has changed for months, other than Roon being updated.

I wondered if the QNAP might have been on it’s way out but, it everything seems to be running smoothly. We don’t use it very often, but we have Plex installed on the QNAP and that is still working normally without any issues. I can successfully stream HD over wireless and wired with no buffering. Disk health checks are all good. Transferring files to/from the QNAP over the network is also fine. Everything is working on song except for Roon.

I’m not sure what to try other than:

  1. Wait and hope. This has been a hit or miss approach in the past!
  2. Delete Roon and start from scratch with a fresh install/database. Haven’t even done this…don’t really want to as it will still involve a lot of step 1!

Any ideas, questions or feedback are most welcome. Historically we have been using Roon from multiple zones simultaneously and on a daily basis. We are heavily reliant on Roon for our music. I would love to get this working again!

Hi @Huw

The first thing that I notice is the QNAP doesn’t quite meet our recommendations and could certainly be seeing some performance problems because of that.

As a test, do you have a different machine that you could temporarily use as your Core, just as a test? Is there any change when using that other machine?

1 Like

Hi @dylan thanks for responding!

Out of curiosity, do you know if much has changed in terms of hardware requirements as of 1.8?
Is there a chance the additional features could be resulting in additional resource overhead?
The only reason I ask is because until now Roon has been running more or less faultlessly.

With that in mind, if we can’t find a fix, would there be a way to roll back to a previous version of Roon?
I don’t really like the idea of getting a new QNAP just to get around 1.8.

A couple of observations from another user who is currently testing functionality:

  • Many radio stations will not load at all, even at low bitrates (128k). Those that do will drop out just like any other media source (local + web have the same issue and we have 100/100 leased line, so I don’t think it’s our internet connection).
  • Sometimes tracks will be distorted / ‘scratchy’. Regardless, playback lasts no more than 2-5 minutes.
  • User interface on Android, iOS and Windows is much slower. “What’s New” takes about 15 seconds to load at best.

We have tried to isolate this as best we can. There is nothing else happening on the network whatsoever.
In the past, we have had no problems streaming to multiple locations, as well as streaming 4k video alongside, so it’s not as if we were close to capacity by any stretch. Far from it.

As far as getting Roon running on another machine, that’s certainly something we can try, though we don’t have any devices besides the QNAP which are powered 24/7. Not sure if that’s an issue?
Is there a way of doing that while maintaining the same database to get as close to a ‘like-for-like’ test as possible? Or would the database need to be copied to the new machine as well. Not a problem, just wondering what the best approach would be.

I will add that this is not a sustainable solution in the long term and I don’t think it’s fair to say that our hardware would be the root cause considering Roon has been running just fine for 5+ years on our existing hardware. It was working fine until yesterday when we did the update.

Hi @Huw

Generally the requirements for Core machines haven’t changed drastically, but for machines that already were below our recommendations the hardware could certainly be pushed past its limits now.

I’d recommend opening up another support topic for this with setup details. Generally these are not widespread issues that we are seeing people face, so we’d need some additional details to help get things up and running properly.

This is definitely a good test. Even if it’s not powered on 24/7, seeing how things perform here will be a helpful data point.

You’d want to follow our migration instructions:

Hi there.
Just wanna join this as I’m also is experiencing this exact problem on my setup after upgrading to 1.8.
My setup is:
Roon Core running on MAC OS 10.13.6 with Intel Core i7 and 8GB RAM (init MAC OS install (no extras installed), used only for Roon Core service).
Audio devices: Well all of my devices stops. Including the DAC M2Tech on a different MAC Mini and a Merridian Explorer 2 connected to the Core.
Both streams stops after a couple of minutes of playing any source of material.
It’s a pain in the butt! Please implement an “auto resume” option in the GUI!:grin:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.