Music suddenly turns to pink noise

Hi @Gary_Gil ---- Thank you for touching base with me and providing a video highlighting the issue you are facing :clap: :thumbsup: Apologies for the delayed response.

Moving forward, my assumption is that all of your settings have remained the same during your troubleshooting but just in case, may I kindly ask you to please provide the following screenshots:

  1. When music is turning to “pink noise”
  • Your “device setup” screen (i.e Roon settings).
  • HQPlayer settings.
  • Signal Path
  1. Roon alone in RoonReady mode using the microRendu (not using HQPlayer).
  • Your “device setup” screen (i.e Roon settings).
  • HQPlayer settings.
  • Signal Path
  1. When I use HQPlayer and bypass Roon entirely and everything else in the chain identically setup.
  • Your “device setup” screen (i.e Roon settings).
  • HQPlayer settings.
  • Signal Path

Lastly, just to confirm, you’re running the latest version of HQPlayer, correct?


I may be way off on this, but I have had the exact same problem for a year, and I’ve been through several computers and now an sms-200. Also the problem has persisted through two different dacs and different software: Audirvana +, jRiver MC, and Roon. I often got the hash/ pink noise when I touched my dac for some reason; so I decided to try running a ground wire from a chassis screw on my dac to the screw of the face plate of the electrical outlet I use for my audio system. I have had no noise for 3 or 4 days now. It’s undoubtedly too soon to declare victory, but you might try something similar. It’s easy enough to do.

Hi @Eric,

For #1 When music is turning to “pink noise”, the screenshots are below. Note, #2 and #3 do not have the problem, but I will still upload the screenshots for you in separate posts.

Yes I’m running the current version of HQPlayer - version 3.16.4

  • Gary

Hi @Eric,

Here are the screenshots for #2 - Roon alone in RoonReady mode using the microRendu (not using HQPlayer).

Hi @Gary_Gil ---- Thank you for the follow up and providing the requested screenshots, both are appreciated!

We are going to do some testing on our end to see if this behavior can be reproduced and once my tech team has updated my report I will be sure to reach out with our thoughts/findings.


Hi @Eric, one other data point I may not have mentioned. I am using the volume control in Roon because I don’t have a preamp at the moment. I don’t know if this could be related to the issue or not, but I thought I would mention this.


1 Like

Hi @Eric,

One more scenario that I just confirmed HAS the problem where a hi-rez track (any track other than redbook or DSD) suddenly turns to pink/white noise.

Direct USB connection from my computer to my DAC, without the Sonore microRendu NAA in the chain. Playback is with HQPlayer + Roon, the same as the other scenarios.

Here are some screenshots of the settings:

1 Like

Hi @Eric, did you find out anything more about this issue?

I can replicate the problem consistently when I use Roon + HQPlayer, whether I connect via USB or ethernet using the microRendu as an NAA. The only file types affected are hi-rez (anything other than Redbook or DSD).

I am now running Windows on my Mac Mini, and the same problem occurs. I have even gone to a direct ethernet connection from my Mac Mini/PC to the NAA (microRendu) hoping this would solve the issue, but the problem is still happening.

Note, Roon is running from a sonicTransporter and I’m controlling it via an iPad. Is there any way I can try to install Roon on my Windows machine temporarily just for testing purposes to see if the problem persists? Perhaps a new installation with a temporary license using a different email address that I install directly on the Windows machine, so my main account with my library stays intact?

Any ideas @agillis?

We’ve found some steps for a similar issue, but the report is still with our development team so I don’t have a firm sense yet whether this is an issue with Roon, or HQPlayer, or if something else is going on here.

Having the reproduction steps is a critical first step, so we’re hoping we can make some progress on this soon. The report is in our queue, and we’ll follow up once we’ve had time to analyze the problem.

Thanks for your patience here @Gary_Gil.

1 Like

Ok great! Thanks @mike

Thanks for the update @mike.

@mike or @Eric did this issue get resolved in a recent Roon update? I’m not 100% certain because I only listened to two or three tracks hi-res tracks last night, but I didn’t experience the issue at all. I will continue listening to see if has in fact been resolved or not, but last night I listened to 24/96 and 24/176.4 PCM tracks without the white/pink noise. :smile:

Which leads me to another question. I control Roon on an iPad and Roon core runs on a sonicTransporter. A few times recently when I started Roon on my iPad, it said there was an update. Does that mean there is an update to Roon core, or is it just an update at the controller level?


Well, unfortunately, the problem is apparently not fixed. I just tried listing to one of my favorite demo tracks Three to Get Ready by The Dave Brubeck Quartet on 176.4kHz/24bit and it made the same white/pink noise shortly after pressing play. Bummer!

What’s really strange though is that it seems to not happen as often, at least on 96/24 tracks.

I’ll keep you posted.

Hi @Gary_Gil ---- Thank you for touching base with us and sharing these most recent observations, your feedback and continued insight are very appreciated.

As @mike mentioned in one of his previous posts, this report is still with our development team who are trying to understand the cause of this behavior.

We’ve found some steps for a similar issue, but the report is still with our development team so I don’t have a firm sense yet whether this is an issue with Roon, or HQPlayer, or if something else is going on here."

The team has been actively trying to reproduce this in house and once we have a better sense of what is going we will be able to provide some feedback :sunglasses:

I understand that these types of situations can be frustrating and I wanted to thank you for your patience, while our team works through this.


Thanks for the info on the issue.

Quick question, I control Roon on my iPad and Roon core runs on a sonicTransporter. When there is a Roon update, it notifies me when I start Roon on my iPad. Does that indicate an update to Roon core, or just an update at the controller level?

Usually it means both – you can check exactly what’s being updated by visiting Settings > About. Note that iOS releases typically lag a few days behind other platforms while we wait for approval from the App Store.

We don’t generally hold back other platforms to wait for iOS, unless there’s a compatibility issue, meaning that if you update your Core the iOS device won’t be able to connect anymore.

This only really happens when there are significant changes to the application or communication protocol (like in our 1.3 release) – in those cases, other platforms are delayed until Apple says “go!” and then they all go live at roughly the same time.

Hey guys…over the past months, we’ve tried to reproduce this several times without success. Tried all three platforms (win, mac, linux, including with NAA), and several DACs including the HOLO Spring (which was mentioned by someone in one of these threads as having this issue). I’ve tried PCM upsampling, DSD upsampling, and replicating settings from the screenshots above.

In general, just from the symptom description, I am running short of explanations as to what Roon could be doing to cause this. Our job is to deliver the bits from the file, over TCP, to HQPlayer, which is not a very error-prone task. 95% of that code is shared when playing via RAAT–most of the complexity is in decoding the file and moving the bits to the right place for transmission to the device. In both cases, the bits are moving out over TCP…very similar.

The idea that Roon is actually somehow generating “pink noise” and transmitting it does not make any sense to me. We don’t have a noise generator, and the results of the kinds of programming errors that we could have in theory do not match the description of “pink noise” at all.

In any case, we were working on this because I was hoping to hear the static, in case the particular sound triggered any explanations or ideas. Sometimes the sound of an artifact or failure is a big clue as to what/where it is. Lots of people use words like “static” or “pink noise” but there are a lot of flavors :slight_smile: .

I was also hoping to maybe make this reproducible to help give @jussi_laako something to try out. But we are not getting anywhere because it doesn’t happen in front of us.

If this is an issue with Roon, we need a technical bug report from @jussi_laako that describes what we’re doing wrong. I am very happy to make any changes needed to fix this, but we really don’t know what those would be yet.

I’m not necessarily sure this is his problem either, btw. It could be an issue with the DAC (I know some DACs that have failure modes that sound like white noise, and some drivers too…not the ones mentioned in these threads, though). But I think the investigation has to start from the DAC side and work backwards.

I suspect this too. For example my Chord Mojo is extremely sensitive to USB errors and goes into noise output mode whenever there’s an error.

With Mojo this is reproducible even on my iPhone 6 playing music with Spotify, out from the Lightning port to the Mojo (through Camera Connection Kit’s Lightning-to-USB). In such case no Roon or HQPlayer involved at all and different OS and drivers too…

A post was split to a new topic: Rupert Neve DAC - music turns to pink noise