Must re-boot NUC/ROCK every time to use Roon

Roon Core Machine
NUC11TNHi7 with 8GB RAM and 500 GB M.2 SS (RAM and SSD both Samsung)
Hardware all new 7/23

Networking Gear & Setup Details
Cox Gateway Connected to NUC via ethernet cable

Protocol: Wi-Fi 5 (802.11ac)
Security type: WPA2-Personal
Network band: 5 GHz
Network channel: 157
Link speed (Receive/Transmit): 866/866 (Mbps)
IPv6 address: 2600:8800:5905:4d00::79c
2600:8800:5905:4d00:49b8:35d0:c5a7:cde1
Link-local IPv6 address: fe80::5e71:daa4:9ae1:5656%6
IPv6 DNS servers: 2001:578:3f::30
2001:578:3f:1::30
IPv4 address: 192.168.0.123
IPv4 DNS servers: 68.105.28.11
68.105.29.11
68.105.28.12
Manufacturer: Intel Corporation
Description: Intel(R) Dual Band Wireless-AC 7265
Driver version: 19.51.30.1
Physical address (MAC): 1A-0B-DF-09-8F-C9

Roon Remote = ipad 9 ios 16.6.1

Description of Issue
Monday I listen to Roon, close the remote app on ipad when I am done - NUC remains on.
Tuesday I wish to listen to Roon again. I open Roon remote on ipad = Searching for Roon Core = no core. If I try to access the core thru browser = cannot connect.

I must re-boot the NUC by holding the power button 10+ seconds until it shuts down - then second press of the power button to restart the NUC and then the core appears on ipad and operates normally (no error messages). After listening I close the remote on ipad - NUC remains on.

Several hours later or Wednesday I wish to listen to Roon again = Searching for core - no core. Must repeat the re-boot proceedure above. Does not seem to matter if I use Roon remote on ipad or if I use Roon remote on Android phone. I have removed and reseated the NUC RAM and SSD (ESD/Anti static protocalls observed) - no change.
Thanks

Are you actually closing the iPad app, “swiping it” closed.?

What is your end point , not clear ?

Are you experiencing any power dips or outages ?

BTW you can do a long press say 1 second to power down the NUC then again to power up , the “really” long press is a hard reset and not recommended (somewhere on Forum)

This sounds like your wi fi or some hardware (end point ?) going into sleep mode.

Can you login to the Web Interface via another means , is there PC on the network ?

can you see this ?

@Wendell_Rogers, welcome to the Community. Just another user, but to add to @Mike_O_Neill’s questions, I want to confirm that you are running ROCK on your NUC and not Windows? If Windows, what version are your using? There have been some Windows updates in the past week that have resulted in reboots and restarting Roon.

Thanks Mike,
Yes - swiping it closed from a double tap of the home button.

End point is a Rose RS150B or Bluesound Node streamers (if ROCK is working they always work).

Stable power grid and very stable internet.

When NUC/ROCK is crashed (not working) only a hard reset will restore it.
When NUC/ROCK is crashed (not working) I cannot access the Web Interface via wi-fi or a PC connected directly with ethernet cable - “unable to connect/not responding”.

When NUC/ROCK is working I can access the Web Interface and everything looks normal. I can reinstall OS, reset database & settings, restart Roon Server etc…

I can shut down the NUC with the power button in Web Interface - then hit the power button on the NUC the next day to start but that defeats the purpose of a dedicated appliance/server.

Thanks
Wendell

You haven’t got some sort of hidden time out somewhere have you

Not sure where ?

As you know Roon Server is designed for 24 7 use its unlikely to be in Roon maybe your end point goes to sleep

Is this a new issue ?

It may be Nuc hardware OS SSD or MB?

Hi @Wendell_Rogers ,

I activated diagnostics mode for your ROCK and I am noticing some seg-faults in the system logging. I suspect your RAM might be failing, you can check this by running Memtest86 for at least 24 hours:

https://www.memtest86.com/tech_creating-window.html

Doing some testing and I discovered that NUC/ROCK crashes approximately 3 hours after a hard reset.

I accessed the BIOS (TNTGL357.0074) and set the system clock to local time which reverted back to UTC so I am guessing that is normal. No change. BTW this is not a new problem - it has existed since birth.

Then I changed the following BIOS settings -
POWER- Disabled (off) “Intel Dynamic Power Technology”

ADVANCED - Disabled (unchecked) “Auto RTC Reset”

Oddly ROCK now has been running for 21 hours +. I am not calling it fixed but it has never run this long before. I dont remember the above BIOS settings being mentioned in the NUC/ROCK installation instructions(?). Going to see how long it runs before doing RAM test.

Thanks
Wendell

1 Like

Sounds like the sort of hidden timer i was thinking about. I am not sure what my clock is set for and it doesn’t have a monitor connected, it shouldn’t matter anyway

The only change I made to the BIOS was to auto restart on power restore as we have a lot of power cuts

Let’s hope thats the answer

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.