My 3 big problems since version 1.7

Core Machine (Operating system/System info/Roon build number)

Microsoft Surface with Windows 10

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wi-fi router from my IT Provider

Lumin D1 streaming on the same wi-fi as my PC

Description Of Issue

So, i have several issues, altough i tend to think all is related to my Tidal account not syncing 100% with Roon:

1-dont have the “new releases for you” on overview:

2-dont have recomendations or more by this artist, when viewing albums:

3-dont have roon radio, says “limited to library” and nothing similar to play:

All of this was working on 1.6 version and i did not change anything from my side.
Also, reinstalled roon core software, turned off firewall and anti virus, all with no avail.

Hoping for your feedback asap.Thanks.
Ricardo Antunes

Hi Ricardo,

Try going to Settings > Services > Edit Tidal and Logout.

Then try logging back in and see if that helps.

Also, please confirm Roon is on Build 537.

Cheers, Greg

Thanks Greg,

Logout and login did not solve it.

My version:

Hi @Ricardo_Antunes1,

It looks like your device might be having trouble reaching out servers. As a test can you try connecting via Ethernet and then rebooting and let us know if that helps?

I had this same issue now for a while using Qobuz. This appears to be a Roon issue more than anything else. Dylan, since you could not fix it for me, let me know if you solve the problem for Ricardo.
Below is my support link that I got tired of fooling around with on my end to no avail.

Hello Dylan and thank you.

With cable the issue remains.

You have several users telling the same as me, please see this as a Roon critical fix as my LUMIN is Roon ready device and i did not changed anything since stoped working .

Please disable Windows 10 Firewall (temporarily), then restart Roon.

1 Like

Thanks Pete but i did that, it is in my first post

Sorry for missing that.

Please try using Google DNS in Windows:

Then reboot Windows.

1 Like

Thanks again.

Configured alternative DNS, restarted Win10… still the same .

Try this:

  • Logout and disable Tidal account.
  • Shutdown Roon Core
  • Find your Roon database and delete the tidal_account file (Database > Registry > Core > tidal_account)
  • Navigate to /Library/Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop, or just delete it
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Reboot Roon Core and login Tidal again
1 Like

Still the same :frowning:

You may let support diagnose this for you, or you can consider reinstalling Roon (with backup database if necessary). Be warned that if the problem lies with Roon backend server processing, then reinstallation may turn out to be a waste of time. Just giving you an option.

(The basis for reinstallation is this. I read someone who purchased a used NUC with Roon Core. He could not get Tidal to work until Roon was reinstalled, about 1-2 months ago. He did not go through the Tidal cache clearing and RAATServer regeneration steps though.)

Meaning uninstall Roon server from my Pc ? I did that too.

Honestly, Roon should fix this asap, if you go into many threads you will see these problems being reported very often from users who had it up and running in 1.6 version, like me

Hi @Ricardo_Antunes1,

We made a change to our servers today that we think might help here. Can you try starting Radio once more and let us know if it’s working for you?


1 Like


Congratulations to all the Roon team !

Ricardo .

Dylan, my interface also works fully now and is no longer a problem. You should have done this solution weeks ago when I brought up the problem originally. If I had not intervened on this thread, it looks like you were going to have Ricardo undergo the same waste of time “fishing expedition” that I underwent leading to nothing being solved. Roon needs to step up its customer support and not waste customers’ time when something does not work, especially when the customer says the problem is most likely on Roon’s end!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.