My core will not update to 2.0

Roon Core Machine

Windows 10 Home, OS-version 18362836, HP EliteBook i5-3220M 2,60 GHz, 4 GB RAM

Networking Gear & Setup Details

Asus AC2400 4x4x dual Band Gigabite router, Netgear GS108, Ethernet, no VPN

Connected Audio Devices

Devialet 800 and desktop (dragonfly), both wired Ethernet

Number of Tracks in Library

Total tracks are 11500, 870 albums, stored on a Synology NAS DS415play.

Description of Issue

Cannot upgrade my core, but get the message that I have the recent version (1.8 Legacy build 1136), although running on Windows 10 home. Furhter I cannot connect, or play, on my desktop as they are on different verision (1.8 build 1105). There is a note “click the update tab” for the deskop, but no tab visable in the window. How do I come around these 2 problems?

Hi @Johan_Nilsson,

I suggest downloading Roon 2.0 from Roon’s site and then manually install it on your Windows machine.

Note: The Roon Core and all remotes need to be on the same version (1.8 or 2.0) to operate.

1 Like

Hi @Johan_Nilsson,

Thank you for your patience in awaiting a response from support. It looks like you’re still on 1.8. Were you unsuccessful in using @Carl’s page? If so, you can use my direct link to download.

Please let us know how we can help!

Thanks,
Wes

Thanks Carl and Wes,

Now been able to update my core, desktop and remotes to 2.0.
However, as I play on my Desktop (Dragonfly DAC) the core say i should select an audio zone. In the settings under Audio I can see that my desktop and dragonfly is enabled, but does not show up as selectable zones. Further I cannot have any of my remotes (ipads and iphone) to control the desktop (cannot select as audio zone). Any Idea what that might be due to?

Hi,

Thanks for the update, it’s great you running 2.0 now.

Some thoughts on the zone issue:

  • Shutdown, PowerOff and then Reboot the Core and the Desktop machine (if nothing else it gives you a good starting point).
  • Check that Dragonfly zone has not been set as a private zone?
  • Check that firewall exceptions are in place for Roon.
1 Like

Hi @Johan_Nilsson,

In addition to Carl’s suggestions, I see an oddity with regard to your core. When I look at diagnostics, the core shows to be a 169.x.x.x type scheme which means it’s not getting a valid IP from the local network. That would explain why remotes aren’t working and also why you can’t see any zones.

How is the core connected to the network? Does it also have a Wi-Fi interface? It might help to turn it off if this is the case.

Wes

Thanks again Carl and Wes!

The dragonfly was set to be private zone (for some reason), there were some firewall stops and i disabled the Wifi for the core and now all works - as before.

Next will be to download ARC…so I might come back :slight_smile:

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.