My iPad w Roon Remote cannot find the Core like it used to

My setup and equipment:

  1. Roon Core is on a Windows 10 desktop computer, with Intel i5 CPU, wired ethernet,
  2. Internet Service is AT&T DSL and the router they supplied is Arris BGW210-700.
  3. My Auralic Aires G2 streamer uses wired ethernet. It feeds MiniDSP SHD Studio, then MScaler then Hugo TT2.
  4. My remote control is iPad 6th gen, OS 13.5.1

My Core is working and I can play music thru the Aurelic G2 and the stereo connected to it. But the iPad using WiFi cannot find the core. I checked that iPad WiFi is working. It is setup and streaming news and web searches.

My iPad as Roon Remote was working up to July 24, but not after. Changes I did July 25 are:

  1. On my desktop computer that has Roon Core, I restored an image of my C drive, that was created June 16. My Roon Core on desktop and Roon remote on ipad was working good in June when I created the image I used to restore C drive.
  2. I changed my AT&T Router from Arris NVG599 to current Arris BGW210-700.
  3. Then I restored a backup of Roon on Core. The Roon backup was created June 21, 2020.
  4. Then I played music from Core to Aurelic G2 and it worked well.
  5. But iPad w Roon Remote cannot find core, and that is the problem I hope we can solve.

Hi @Robert_Blakely,

If you reboot your Router, Core and iPad, does that help resolve the issue?
Is your iPad connected to the same network as the Core (and not on 4G/LTE)?

I powered off the Core, modem, and iPad. Powered on modem and waited for broadband light to stady green on. Then powered on Core desktop and started Roon Core. After that I turned on iPad. The iPad still cannot find the core. The iPad is using WiFi with SSID and password, and it is able to browse internet. The ipad can run Auralic Lightning and see the Auralic Aires G2 that is on wired Ethernet.

My core is connected to the same router as the iPad. Core uses wired ethernet and iPad uses WiFi, but both from same router. My iPad does not have cellular at all. It is model MR7J2LL/A

Have you tried turning off the windows firewall to troubleshoot this. windows updates love to mess with this stuff.

Just now, I did “Turn off Windows Defender Firewall”, but ipad still cannot find core. Then I turned firewall back on.

can you see the windows machine IP address with something like FING APP?

Just now, I installed Fing on iPad and ran it. It does show my Core desktop name and IP. Still, Roon Remote on iPad does not find the core on desktop.

Last night, after i re-setup my email accounts, the iPad found the core for about 4 seconds, and I tried to click on it to use it, but just before I could lower my finger, it went away, and I can not get it back.

Here is my log files from just now. Logs on OneDrive

Just now, when I rebooted desktop and while Core was just starting, the ipad found it, and I clicked it, but it could not connect. It tried to connect a few times but could not succeed. After the Core was fully loaded, then it can not find core. Same problem.

By the way, everytime I start the core, it takes about 4 or 5 minutes to scan 160k files. Is it supposed to rescan every time it starts?

Hi @Robert_Blakely,

Is there any change in behavior if you try to reinstall the Roon iPad app from the Apple App Store?

I wonder if this restore could have caused Roon to load back up incorrectly, we suggest using Roon backups when restoring as snapshots of the “live database” can be problematic. Do you have any proper Roon backups in case this is the cause?

when I re-install Roon remote on iPad, it still does not work.

My music and my RoonBAckup are on a NAS, not on C drive of desktop that runs core. Does that matter?
I am not sure what you mean by

“we suggest using Roon backups when restoring as snapshots of the “live database” can be problematic. Do you have any proper Roon backups in case this is the cause?”

Hi @Robert_Blakely,

By this I mean you used a program to copy the Roon database contents instead of using a proper Roon backup, one created from within Roon.

The Roon database still lives on the C: drive, even if your Roon Backups and Music are on another drive. Does this mean you have a proper Roon backup from before you cloned the drive? I would suggest the following, try using a fresh Roon install:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if you are able to connect to your Core on the new install (don’t restore just yet)
  • After testing fresh library for a bit, restore from backup before hard drive was cloned

Did everything you suggested in bullets 1 thru 5. The ipad still can not find the core.

If ipad runs roon remote, and I close roon on core, then restart roon on core, then the ipad finds the core, but cannot connect, then after roon core is fully running, the ipad cannot find the core.

Thanks for giving those suggestions a try @Robert_Blakely.
Do you by any chance have any other PCs or Roon Remotes you can try to use?
I would like to know if the issue just affects this iPad or other remotes as well.

tried my iPhone and same problem. I deleted the app and re-installed the app, and same problem.

For what it’s worth, I recently had a problem where my remotes could not find the Core. The problem occurred after I made WiFi changes and had connect fresh from Windows. Here was the problem: I mistakenly established the network related to the Core as “public” rather than “private.” With public, other devices could not see the Core machine. I changed it to Private and everything started working again. Took me 1+ hours to figure that out.

1 Like

I installed Roon on my windows laptop to use a remote, but it cannot find core.

Brain Cohen, when I saw those dialogs on my install for desktop and laptop, I checked private, and unchecked public. On iPhone and iPad i do not recall being asked. How do I back check it to double check?

I only needed to change to “private” on one device - the computer running my Core. I may have restarted the computer after.

1 Like

On my core desktop that uses Windows 10, it only uses wired ethernet. It does not use WiFi and does not have any WiFi equipment. On Windows firewall it showed for “Inbound rules” there are 2 of raatserver.exe both blocked for public, and 2 of raatserver.exe both set to allow private connections, and 2 of roon.exe set to block public, and 2 of roon.exe set to allow private. Maybe the problem is I have 2 of everything?
For outbound rules I do not see anything for Roon or raatserver.

My router uses both wired and WiFi. My ipad uses only WiFi.

Hi @Robert_Blakely,

This sounds like the Core itself has a firewall issue. I would remove any Roon.exe / RAATServer.exe and I would manually re-add them.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

I followed your instructions. After deleting all the firewalls for roon and raat, I confirmed they did not show up in “Inbound rules”, and did not show up on “Allow apps”. Then, in “allow apps” I added to allow:

C:\Users\lakel\AppData\Local\Roon\Application\Roon.exe

C:\Users\lakel\AppData\Local\Roon\Application\RAATServer.exe

They first appeared with Public checked, so I checked Private and unchecked Public. And it looked like this: allowed apps.

then I close, and reopen, the allowed apps and it looks like this: look again at allowed apps . I assume if the first column checkbox is not checked, then it is not enabled, and has no effect.

then I go back to “Inbound rules” and I see this: look back at inbound rules
I do not understand why it doubles.

And iPad cannot find the core.

Hi @Robert_Blakely,

I would manually remove the existing entries and re-add them by specifying the folder path, under %localappdata%. I would add the exceptions in place for both public and private (in case you accidentally set your network to the other type).