My iPhone and iPad don't connect to my iMac Roon core anymore

Core Machine (Operating system/System info/Roon build number)

iMac 27" 2019, Catalina (10.15.1), Roon 1.6, build 475

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Amplifi Mesh system

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

My iPhone and iPad don’t connect to my iMac Roon core anymore

Hi @M_Beer,

When this this issue start occurring? A few days ago? More/less? Did anything change during that time such as an Operating System update or new router firmware?

Can you check to see if both Roon and RAATServer are still listed as exceptions in your Mac firewall? You can use these instructions to check. I would also try temporarily disabling any other firewalls you may have (e.g. Bullgaurd/McAFee/Kaspersky/ect.).

It started apr. 2 weeks ago. Only changes were/was update(s) of Mac OS and IOS/iPadOS.
I do not use a firewall. I’ll check via your instructions.

1 Like

This happened to me recently. In my case it’s due to the wifi somehow being turned off on my iMac and I’m unable to turn it back on. I’m pretty sure this coincided with updating to Catalina (grrr!). Occasionally the wifi will randomly come back on, then go off again. I’ve tried some fixes others have recommended but so far haven’t been able to fix it.

@rrwmd - is the behavior the same if you connect your Core via Ethernet? If that doesn’t change anything please open a separate support ticket outlining your setup.

I just waited for the new updates on Mac and iPhon/iPad, but still no luck. The iPhone app does find Roon on my iMac, but keeps trying to connect, without success… Can you please help me?

Hi @M_Beer,

Can you try reinstalling the Roon app on your iPhone? You can do this by press and holding the app in the main iPhone screen, clicking the “X” that pops up and then re-downloading from the app store. Does that help?

Thanks, I did that a few times, and still no connection… The Roon remote on my iPhone sees the Roon Core on my iMac, but still isn’t able to connect. It keeps trying and trying, but no connection.

Hi @M_Beer,

Can you provide more details on the network setup? Are both the Core and the iPhone connecting to the same Amplifi node? Are they on the same subnet?

Do you see an error message listed? If so, what is the exact error it displays?

Have you rebooted your Core, Network and iPhone yet? If not I would also give this a try.

Hi, thanks for your answer. I did all you suggested already. The funny thing is that the iPhone remote app (latest update) does try to connect over and over again, and it finds my core (iMac running Roon 1.7 build 700 stable), but it doesn’t succeed in connecting. Both the Core and the iPhone are connected to the same Amplifi node. So, what else could it be that goes wrong? I don’t understand…

Hi @M_Beer,

Do you have a VPN installed on your iPhone? If you have another PC around the house, can you try installing Roon on that and let me know if you are able to connect to the current Core?

Hi Noris, I don’t think I have a VPN on my iPhone (How can I tell?) I can’t connect my iPad Roon remote either, so I think it must have something to do with my iMac. I will try my MacBook to see if it works from there.

The MacBook was not the solution: just the same as with my iPhone and iPad: no connection with the core on my iMac.

Hello @M_Beer,

Ok, this is good, even though it might not seem like it we’re making progress here. We confirmed that this issue affects multiple remotes trying to access the iMac Core, so either something on the iMac is preventing this access or it’s something on the network.

I would next like to rule out the iMac, can you temporarily host your Roon Core on the Macbook instead of the iMac? You can do this if you navigate to Roon Settings -> General -> Disconnect on the “Choose your Core screen” - Select this PC -> Unauthorize (since you only have one license) -> Authorize the PC and login -> Verify if your iPhones exhibit the same behavior on there.

If I use my MacBook as Core for Roon, my iPhone remote works like it should. So now we know that it has something to do with my iMac?

Hi @M_Beer,

Thanks for confirming that the Macbook works as expected. Yes, this does seem to be related to the iMac or how it is connected to the network. When you were using your Macbook as the Core, was it connected in the same fashion as the iMac?

I propose we try to set aside your current database to see if it helps. To do so, you can use these instructions:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • Try using fresh database for a while
  • Restore from backup

Thanks for your suggestions. I’ve tried this, and still no luck… The iPhone Remote tries to connect again and again, but it doesn’t succeed to do so. Also not with the ‘fresh’ Roon back up. Could something in my iMac settings prohibit the connection of the remotes (iPhone AND iPad)?

Hi @M_Beer,

Thanks for giving a fresh Roon install a try. Since this behaves the same way, affects all your Roon Remotes and the Macbook does not exhibit this, it’s safe to say that something on the iMac is preventing Roon from communicating properly. Do you have any antivirus or firewall applications installed on your iMac? Applications such as: Kaspersky/Little Snitch/McAFee/Bullguard/Avira/Avast?

Thanks for staying with me Noris. I’ve already checked: I don’t have any antivirus or firewall applications installed, as far as I know. I used to, but not anymore. Is there a way to make 100% sure that there are none left behind? It’s funny that this problem seems to have occurred since the installation of Catalina, but that couldn’t be the problem, can it?

This is what I get al the time