My iPhone cannot connect to Roon via some Access Points on my network

Core Machine (Operating system/System info/Roon build number)

2014 iMac QuadCore, 1 Gb disk, 16Gb memory

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

  • Yoigo Main Router - Living room - 2.4 Ghz & 5 Ghz WiFi, DHCP server active - Gateway to internet
  • Secondary router TP Link - Study - connected by ethernet to Yoigo Router - identical SSID to extend WiFi network on both bands - DHCP server OFF.
  • The iMac is connected with an Ethernet cable to this router.
  • A third TP-Link WiFi repeater in the basement is connected by cable to the main router and also uses the same SSID.

I extended my WiFi network by adding a few more Access Points. Because they have the same SSID and settings it acts as one large network. I have good internet connectivity anywhere in this network.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

  • Google Chromecast connected to WiFi signal of main router in Living Room, connected to a DAC, amp & speakers

Description Of Issue

When I try to control ROON with my iPhone (or Android phone or iPad) it often does not connect.

  • When in the study, connected to the secondary router, I get connection to my Roon server and I can control my music, and have the ability to send that music anywhere, including the Chromecast
  • When in the living, connected to the primary router, I often do not get a connection to ROON. Nevertheless the devide has a good WiFi connection and can browse the internet, listen to Tidal, etc.
  • Moving back into the study the iPhone will pick up the other network and will connect again. Likewise moving out of the study, reconnecting to the primary network, will cause the connection between the ROON App and the server to drop again.

Hello @Edward_Jenner and welcome to the forum.

While waiting for official support to catch up with you, you might want to make sure that all your devices are on the same network:

Also the Knowledge Base Article: Networking Best Practices might be worth reading.

Hi @Edward_Jenner,

Welcome to the community.

I looked up this router and it appears to be an ISP provided router. We have found that often times, ISP-provided equipment do not properly pass multicast traffic through, and proper passing of multicast traffic is essential for Roon to work properly.

I would start off by confirming that everything is on the same subnet range as @BlackJack noted. If they are indeed on the same range, you may want to try disabling the WiFi/DHCP capabilities of the Yoigo router and use it only as a modem (to convert the ISP feed to Ethernet) and attach one of your consumer-grade routers to the Ethernet output instead.

Hello @BlackJack ! Thank you for the advice. Indeed everything is on the same IP Network

Hello @noris ! Your advice solved it for me! Thank you!

  • The ISP Provided Router is a ZTE H367A.
  • The secondary Router a TP-Link Archer C9.
  • The repeater is a TP-Link RE305.

I deactivated the WiFi antennas on the ZTE, and put the repeater (RE305) from the basement next to it, and that works, and that solved the problem. I will simply buy a new repeater for the basement room.

When I have a bit more time I will look into moving the DHCP server from router 1 to router 2 and see if I can then use the WiFi on the ZTE router. I will update this post if I learned anything form that,

1 Like

Hi @Edward_Jenner,

Glad to hear that my suggestion resolved the issue! Just as a side note - range extenders have sometimes caused issues with Roon as well, when I tried a few on my end I found that I was unable to stream content without dropouts.

Generally speaking, we have found Mesh-style networks (such a Eero/Orbi) be be more robust for a Roon setup, but your mileage may vary. I just wanted to mention that little tid-bit to keep in mind, but happy to hear the main issue has gone away. Take care!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.