My Kindle Fire Remote Doesn't Work After 1.8 release

Roon Core Machine

Relatively new PC

Networking Gear & Setup Details

Netgear Orbi 750 mesh

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Roon appears to load on the Kindle Fire. It asks me to connect the Roon core. After I choose my core, I get a message that a software update is needed. It indicates that my Core is up to date (it is), and that my tablet needs an update. It lists the software on the tablet as “1.8 (build 831) stable.” Next to that information is a soft button connecting to Google Play, reading “Check for update.” I can connect to Google Play, but this being a Kindle device, I can’t access any update there. If I look for an update through Amazon, none is listed as available for Roon.

The Kindle is a Fire HD 10 (7th generation). Its software is current as of today (Fire OS

Others are saying there is just a delay in the update showing up in the Amazon app store. I wonder if you can install the Android APK from the Roon download page?

I have the Google Play store installed on my Fire tablet, so I was able to update that way.


Thanks Jodi! I had the same issue with Roon Remote from Amazon App store. It doesn’t work with my Roon Core after the latest update. After reading your message, I downloaded APKs, followed the instructions to install the Google Play store on my Fire 10 (9th Gen), and downloaded Roon remote. Now everything works fine :slight_smile:


I’m glad it worked out for you, and having the Google Play Store on there makes life easier. Just a note though…if you use Amazon Alexa on your tablet, don’t let the Play Store update the app. It will probably break it. There’s a box you can check somewhere to disable automatic updates for specific apps.

Same problem… I hope it’s just taking time to get approved or something. I have a samsung tab too, but I use the Kindle in the other room.

I don’t want to install the Google Play Store because it slows the already slow Kindle down.

That worked!

1 Like

I saw Amazon finally posted the update! Disaster averted :slight_smile:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.