My laptop wont function as a remote as it did yesterday and now seems to operate as a second core

Set it up yesterday and worked fine…switched on today and the Macbook I had configured to act as a remote to a MacMini headless server wouldnt connect as a remote and through endless fiddling now seems to be a second core operating off its own library…how do i change its status? I tried de-installing Roon on the laptop and starting again but that didnt work . Using the forum as a means of answering this question is very frustrating…

What makes you think it is running as a second server?

Hi @diw – sorry for the frustration!

Configuring two Roon installs to both run manage their own libraries shouldn’t be possible with a single membership.

Can you open Settings on the laptop that’s supposed to a remote and let us know what Library you’re seeing? You should be able to confirm your setup there, and we can figure out the connection issues once we know what’s going on.

when i open Roon on the laptop it shows the itunes library thats on that machine and in settings it has “this Mac” as the library…it also plays albums on Roon on that machine…i would be intrigued if I had found a way to hack the membership process but I cant claim I know how I did it

Hi @diw – on the mac mini, it also says the library is “This mac”, or does it say the library is your macbook? And did you get a message about de-authorization at any time? I wonder if in your fiddling you deauthorized your mac mini and now your laptop is the installation that manages your library.

You should only be able to run one instance of Roon that manages your music library, so if both are saying that “This mac” is the library then we’ll follow up further to grab logs from you.

At the moment, both installations are saying This Mac as the Library manager…I just got a message on the Mini to deauthorise the Macbook as the Library manager and I have done that, for maybe the third time this afternoon, but that doesnt affect the laptop settings or its operation. I do remember setting the Macbook up as a remote but not undoing that before it spontaneously stopped working as the remote this morning

One confusing thing about the interface…in the Settings, Setup window…Machine name refers to that machine, not the machine that can connect as the remote, is that right?

the support process seems to have ground to a halt or have I responded to the wrong place? I know that there isnt a roomfull of Roonies somewhere who are rushing around just answering my query but a simple acknowledgement would be friendly? On the macbook I get two screens, one which invites me to choose a library on this mac whilst it fails to find remote libraries. When I hit continue, I get another screen called Authorisations which shows Macmini as the library manager and invites me to pick the Oops button, whereupon it just goes back to the first screen in a loop which has no means of resolution…couldnt upload the screen shots to this post…thoughts?

@diw - not with Roon but as you had a post on CA as well - posted a suggestion there for you.

Hi @diw – sorry to have left you without a reply here. We did fix the confusing text you mentioned above today, but obviously we still need to get your authorization woes resolved.

If you’re still having problems here, let’s make sure you know which Mac you want to actually manage your library. Then, let’s uninstall completely on the remote side, and start fresh.

You can do this on the Mac you want to be your remote by navigating to /Users/[@diws user name]/Library/ and deleting the Roon folder.

Once you’ve erased the Roon folder, make sure things are working properly on your main Roon install. You should be able to start up without any questions about your license. This normally isn’t necessary but I’d really like to get you in a “fresh out of the box” scenario.

Finally, on the newly-cleaned remote Mac, reinstall the app from our download page, and during initial setup, you should be able to select “I want to use this as remote control”.

Let me know how that goes, and hopefully you’re all set! And if not, I’m sure we can get you squared away here. Thanks for your patience @diw

My understanding is there are potentially two folders on the Mac to delete.

a. /Users/USERNAME/Library/Roon

b. /Users/USERNAME/Music/Roon

Then delete the application from the Mac, and download a fresh copy from the Roon site.

And that it would be of value for him to check the Roon Core installation to ensure that under Settings, in Setup that Accept Connection from Remotes is set to "Yes.

have de-installed Roon on the remote and checked that both folders refereed to are gone, but reinstalling the software just gives me the same two screen sequence without the option to install as a remote…I remember that step from the first time I installed it…the routing sequence to get to the folders is slightly different in Yosemite but I have checked through Spotlight that all references to Roon were gone but maybe it has not completely de-installed?

If you go to Finder, under the Go menu choose “Go to Folder” and input “/Users//Library” , do you see a Roon folder?

Can you post a screenshot of the two screen sequence you mention in your last post?

Tried that access route but it says it cant find the Users/Library folder…on this Mac access to the Library folder is via the machine name in the Devices menu….unless that is another Library ?? below are the screen shots on the Remote…click continue on the first, you get the second, choose OOPs and you go back to the first. Dont think this uploading works… let me know if it doesnt or email me directly at

Apologies - somehow the path got shorted, it should be /Users/username/Library

in example, on my Mac, /Users/bplexico/Library

That folder opens and among other folders in that Library folder is a Roon folder.

I think the confusion here may be about the term “Library” in our setup screens. A Roon license allows you to manage your library on one Mac or PC.

If you’re trying to set up a remote and choosing to manage your library on that PC, that’s going to be the issue that’s got you going in circles here.

Unfortunately, from your screenshots it looks like you’re not seeing your main Roon install when you’re setting up your remote. Assuming I’ve clarified things with regards to library and remote setup (ie, you should not be choosing ‘This Mac’ on remote), can you let us know if you’re unable to connect, and we can go from there?

Really appreciate your patience here @diw

OK…deleted the Roon folder…downloaded Roon again …after some stuff about lidb commands failed to install I got the choice screen where I clicked on "I want to use this Mac as a remote control “and it took me to the next screen saying” I want to use this Mac to manage my music library "which I dont believe I do, right? I have done this twice now just to make sure I was pressing the right button…

Yeah, that is definitely not what we’re expecting. I’m going to follow up with you via email @diw.

After some extended troubleshooting, @diw and @kevin have determined that this was a an issue with the OSX firewall.

We’re looking into a workaround. We’ll be posting more info soon, but if you’re in a similar situation you may want to turn off your firewall until we have an update.

Thanks everyone for your help tracking this down, especially @bplexico and the endlessly patient @diw – more soon!



Interesting, the OS X firewall is turned on my laptop ( running as a remote) and is turned off on my Mac Mini which is running Roon Core. Everything works fine.

If I also enable OS X firewall on my Mac Mini then it also works. But here is why, with Roon Core running on the Mac Mini as soon as I turned on the Firewall I got a dialog box on the Mac Mini.

Do you want to allow incoming connections from “mono sgen” ?

I choose yes/accept.

I bet if I choose Blocking incoming connections for “mono sgen” in the Firewall options settings it will no longer work. So I tried that and sure enough I cannot connect to the Room Core from my Macbook (remote), I get the screen in Roon that states "REMOTE CONNECTION - Waiting for Remote Library. Select a different library.

Once I got back to my Mac Mini, choose Firewall, and select options, if I toggle it to "Accept incoming connections from “mono sgen” than everything works again.

So I suspect all he needs to do is make that change in his firewall options.

Make sense?

p.s.Same applies for any Mac running the OS X firewall as a Roon remote. You will get prompted to accept incoming connections from “mono sgen”. You need to accept. Or correct in firewall options to accept.