My Linux system and networking are often disconnected

Roon Core Machine

Model: MeLE Fanless mini PC Quieter 3C
CPU: Intel Celeron(R) N5105 @2.0 GHz, 4core CPU
Disk capacity: 379.8GB( included 256GB SSD)
OS: Linux Ubuntu 22.04.2 LTS (64bit), GNOME ver:42.5, Windowing System:X11

Networking Gear & Setup Details

I am using Netgear’s RAX 45 (Wifi 6) router and I am using Half Giga network.
Public repeater → Public router → RAX45 → Wired PC (Roon server on Linux ubuntu) &
Wired Audio device

Connected Audio Devices

I am using Naim Uniti Atom and this device is wired to the same router as the Roon server. As you know, Atom is a Roon ready product.

Number of Tracks in Library

I’m only using Tidal streaming service. There are no tracks or Albums in my PC

Description of Issue

I can’t listen to music because Roon suddenly disconnects.
At this time, when I checked the connection status between the router and the roon server,
I couldn’t see the roon server.
In this case, after rebooting the PC, it is confirmed that the connection is normal.
However, it also disconnects again after a while and repeats the same phenomenon.
This phenomenon used to be very rare, but it is happening almost every day these days.
The only way I can solve this is by physically powering off the PC.
I don’t think there’s any other software interference because my PC is only operating
for the roon server.
I don’t know what to do. I ask for your help.


[Roon remote error]

Welcome to the Roon community, @David_Sakong.

Most likely, this is a problem with the way your Ubuntu system is setup. As a first step, can you log into the Ubuntu desktop when the machine drops off the network?

If you can, what’s the status of the network indicator? You may also type nmcli connection in the terminal.

It could also be the PCs network port failing. Not sure if Ubuntu has the drivers, but, if it does you could test by getting one of those USB to ethernet adapters and see if the network connection is more stable.

Thank you for your reply.
I was watching Roon server on VNC, so I couldn’t know the network situation when there was a problem. However, as you can see in the picture above, the connection status of the router shows that the Roon server is not connected. I wish it was a Ubuntu setup problem, but I’ve been using it well. This problem has been occurring continuously for the past month and is increasing in frequency.

Thank you for your reply.
The method you mentioned could be one way, but my PC doesn’t have another network port.
There’s no way I can try at the moment and I don’t know much about Linux systems.
So I’m going to reinstall Roon after reinstalling Linux.
I’m hoping for a good result.

That’s the IP address of the Linux box running Roon Server, so it is a networking problem for the entire machine, not Roon.

When the server disappears, you need to access the machine directly (since VNC won’t work) to diagnose the network issue.

Hi, @David_Sakong.

Coincidentally, I have a similar MeLE PC due to arrive today. I don’t plan to use it as a Roon core but I’ll be installing Ubuntu Desktop LTS. If I run into network issues, I’ll pop back on here.

I was going to propose an ethernet adapter but I see that @Rugby already did. This is a good route to go if you can’t stabilize it any other way.

Hi. Thank you for your advices.
I reinstalled the Linux for the ROON server and reinstalled the ROON server.
Since then, no problem has appeared a day later.
However, the unusual situation I found was that I saw several tasks related to ROON
on the Task List before, but I couldn’t see tasks after reinstalling Linux.
Of course, Roon server is working well.
Another peculiar thing is that the Ethernet attribute was previously identified as 1 Gb,
but now it is identified as 100 Mb.
There was no configuration that I changed, but I think there was an unknown problem.
In conclusion, it seems that the problem was solved after reinstalling Linux and ROON server.
I appreciate a lot of your advice.

It looks like there may be an issue with this device running Linux.

1 Like

Though apparently only if an internal NVMe disk is installed. Or even, possibly only if the Linux OS is installed on the NVMe – not clear.

Thanks for this link.

I mentioned that I had a MeLE PC inbound. It’s a Quieter HD3Q which arrived on Friday. I went with this version for the extra RAM. It’s maybe a bit pricey relative to its specs, but I wanted something low powered, fanless, turnkey, and available for quick delivery.

I’m using it for something similar to what the author of that article is doing - in my case, it’s initially Pi-hole and a little app called Scrypted that connects the dots between UniFi Protect cameras and Apple HomeKit. It needs to live on my IoT vlan (I’ve got Pi-hole running elsewhere, but need this on that vlan for reasons I won’t bother you with.

I’ve got Ubuntu Desktop (Minimal) 22.04 on the included NVMe. Also SSH, RDP, Docker/Portainer, and the apps I mentioned. So far, no networking hiccups whatsoever. Ubuntu’s installer and the installed OS see and drive the port just fine. No drops, no evidence of any issues.

The article suggests that the issues may be specific to the 2Q and 3Q, which are different that the 3C @David_Sakong has and the HD3Q I have, though it’s not clear how different from one another these models actually are.

I’m having a decent experience with the box overall. Have a bit of an issue with video out over HDMI - the screen flickers on and off frequently - but I didn’t spend much time on that since the box will be headless.

@David_Sakong - you mentioned that your device is now connecting at 100Mb. You’ve got an issue somewhere - could be software, could be your cable or switch. The ethernet port on your device is a Gb port and it should auto-negotiate at that speed. If you’re happy with 100Mb and everything is, and remains, stable then you have the option of ignoring it. If you have issues, though, you might want to figure out where the issue is.

@Rugby - I saw that you folks chatted about these little boxes at your latest online call. I should pop into one of those and see who you people actually are. :slight_smile:

1 Like