My Live Radio Problem after Update 1.8

I’m trying out the new update and like it so far, other than problems with My Live Radio. All of my old saved stations show, but when I click on any of them I get an error message that “Station Unavailable Station No Longer Exists”. When I try to browse Live Radio stations and add them back, none show up. Seems like a firewall issue, but I confirmed the new Roon update is setup for full access in my Firewall Bitdefender. Any thoughts?


Same here. All radio stations are ‘dead’ and I can’t add any. When I click on ‘browse live radio’, nothing happens. Is it a firewall issue? I have a Nucleus, tried restrating it, but nope… What should I do?


Roon 1.8. Same. Stations not found and no other live radio stations are visible.

1 Like

same here :frowning:

1 Like

same here. Hi Roon - can we have a solution please


Same. Stations not found and no other live radio stations are visible.

The last thing I played yesterday was radio. I clicked the “play” control at the bottom and the radio started playing. Still can’t use the Live Radio or My Live Radio functions, but I have radio streaming on 1.8 now.

also noticed I cannot connect when trying to Configure Roon Core in Setup - core is never found - everything was rebooted too

Live Radio is dead for me as well. Suspect it is a Roon service for Live Radio that is not up and running.

Same problem with 1.7 (I still have yet)

Well, I started this thread after trying the normal troubleshooting steps to no avail. I just rebooted my home network and PC again, and now the Internet Radio Stations all are playable from My Live Radio and I can search for new stations as well. I didn’t change anything else in my Firewall settings, just did another set of reboots a few hours after installation.

Odd way to resolve, but for now I’m good. I hope others are successful!


Thank you! I just did the same and it fixed my issues. Working properly now.

I have lost BBC stations and more. I have found only one local station that works. Rebooted Roon core on Qnap.
I have re booted my QNAP TVS471 device completely and still no progress on My Live Radio…

1 Like

Same here no acces to radio stations after update, rebooting didn’t fix it sadly enough.

Hope they fix this soon.

1 Like

Same problem here, no live radio after updating to 1.8.

Working now - hooray

Restarted tablet and app today and live radio is up and running again. Hooray!

There is a separate problem with geo-restricted streams; these are being incorrectly blocked to everybody. I have temporarily lifted the restriction on the main BBC streams which will circumvent the problem for the time being, but there are many others.

Live radio is working now, thank you for solving the problem!

1 Like

Live Radio working for me now BBC Radio 5 Live

Thanks alot for the quick fix, works now!

Great update btw

1 Like