My Mac slows once Roon app is activated

Core Machine (Operating system/System info/Roon build number)
MAC - Catalina 10.15.2 with Roon 1.7 version.
Nucleus ( with version 1.7

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Ethernet cable to Nucleus and to MAC (although MAC is WiFi active as well).
From there it’s WiFi to my 4 Roon ready devices.
NAD 388 Amp with Roon ready card.
Bluesound Pulse Mini
Bluesound Pulse Soundbar
Bluesound Pulse Node 2
All have strong WiFi signal strength

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
When I open the Roon app on my MAC it make the computer very slow, with the beach ball graphic
spinning a lot. The Roon app itself is slow, it will close for no apparent reason and doesn’t work well at all.
The problem has got worst since the last version upgrade. Also the blue spinning wheel in the top right hand corner doesn’t stop spinning.
Prior to opening the Roon app on my MAC, my MAC works perfectly fine. There is plenty of memory on
my MAC.
I also use the Roon apps on my iPhone and iPad and they work well with no problems.
I have contacted Apple support and they believe it’s a Roon problem.

Any help would be appreciated.
Best, Neil Perryman

Hi @Neil_Perryman,

What is the CPU and GPU usage like on the Mac when this is happening?

Can you click the blue spinner and share a screenshot of what you see?

When did you do the update to 1.7?

Hi Dylan, Here are the screen shots, I’ve also done a screen shot to show the CPU%.
The spinning blue circle has been on 22/42 files for days.
I can’t remember exactly when I updated to 1.7 but it would have been soon after it’s release.
Best, Neil.

Hi Dylan, It’s now been about a week since I first made contact with you. Here’s an update on the situation now.
- The blue spinning circle is still at 22/42 files.
- CPU% is now almost always above 120.
- The computer is now very unresponsive across all it’s functions esp. email
I’m constantly having to restart it to get it to function for a while.
- The Roon apps on my iPad and iPhone are working with no problems as is the Nucleus.
Looking forward to your responce.

Hi @Neil_Perryman,

Apologies for the delay in getting back to you here. I’m looking over your report and it looks like there are a few symptoms, let’s focus on each one individually:

Have you tried rebooting your Nucleus and MacOS yet? Is the re-scanning files still stuck at 22/42 following a reboot of both?

Have you tried reinstalling the Roon Client on your MacOS? I would give this a try to see if it helps, to do so you can use these instructions:

  1. Exit out of Roon
  2. Navigate to your Roon Client install on the MacOS:
  • Open Finder and click Go in the top bar
  • Hold down the Option key (or Alt)(⌥) to unhide the Library folder
  • Click the Library folder
  1. Find the “Roon” folder
  2. Rename this “Roon” folder to “Roon_old”
  3. Download and install the Roon MacOS app again from our downloads page
  4. On the “Choose your Core” screen, select the Nucleus as the Core
  5. Verify if the same behavior is occurring with a fresh Roon client install

If you have any issues with the above instructions, just let me know and I can clarify. Thanks!

A post was split to a new topic: Roon Performance Issues

Please see my thread - posting for awareness

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.