My problem with Roon ARC it doesn't work

Roon Core Machine

Aspire TC -710, Intel(R) Core™ i5-6400 CPU @ 2.70GHz 2.71 GHz, RAM 8 GB, 64-Bit-Betriebssystem, x64-basierter Prozessor

Networking Gear & Setup Details

Fritz Box 7590, no VPN

Connected Audio Devices

Cambridge Audio Azur 851N, WAN Connection

Number of Tracks in Library

60.000 Tracks

Description of Issue

I would like to use the ARC feature, but it doesn’t work. Please, see the Roon notification below. My Router is AVM Fritzbox 7590. Maybe you can give me an instruction to configure my router manually. I think, there is an problem with my IPS - Deutsche Glasfaser and ipv4 or ipv6.
Thank you very much!
“ipv6_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“2a00:fff:ggg:hhh:iii:jjj:kkk:lll”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<?xml version=\"1.0\"?>\n<s:Envelope xmlns:s="\” s:encodingStyle="\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n403\nNot available Action\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>”}

@Norbert_Hiller, the diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

There is a useful guide a user posted on how to configure port forwarding on a Fritzbox 7590 for ARC also:

Robert, thank you for your answer and help! I configured the port manually with this guide, i disabled the firewall but nothing happened, there is no connection.

Norbert, are you seeing the same error message in Roon ARC? Is the Fritzbox the only router you have, or do you have another router in your home network?

Yes, i see the same error message and i have got one router only.

I feel your issue is you ISP. Not sure where Roon is with IPv6 support with Arc. Anyone else able to share.

1 Like

I read a note in the router, that the ipv4 address isn’t a publicly accessible. Sharing on ipv4 home network will therefor probably not work.

This might interest you

1 Like

Hi Norbert what device are you running your Roon Core on?
You could install TailScale on this if it is not a Rock based system.

There are a couple of threads on this and it might be a useful option for you. I am running it on a Synology device that is not my Core.
With subnet routing enabled this worked really well for me in the early days when things were not very reliable with ARC

1 Like

Hi Michael, thank you! My Roon core is running on a Nucleus.

Sadly that’s not going to help you.
If you had another computer, that would work, but find the threads and do a bit of reading and see if it could work for you.

CGNAT is a barrier otherwise to running internal servers

Hi @Norbert_Hiller,

Thank you for your report and the team is sorry to hear that you’ve been experiencing a CG-NAT related blockage to port forwarding as a result of Deutsche Glasfaser’s dual-stack lite implementation.

As of now, ARC does not have an in-built mechanism for negotiating the address translation imposed by your ISP. However, as other users pointed out above, the Roon team is making excellent progress in testing IPv6 compatibility that should allow users in your situation to automatically configure port forwarding.

In the meantime, you’ll unfortunately need to rely on one of the workarounds posted in our #tinkering section, including Tailscale or other VPN options: Tailscale implementation with ARC to circumnavigate ISP CGNAT.

Please keep an eye on the main Deutsche Glasfaser tracking thread, as we will be posting updates there as soon as ARC has IPv6 compatibility available.

Hi Connor Schake,
thank you so much for your answer!
I’ve already spent hours to get the ARC app working :-(…
I hope that it works with IPv6.
Best regards

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.