My Roon Core is not getting an IP address

I unplugged everything because of thunderstorm and I can’t see my Roon Core. I have Google fiber router and modem, UpTone EtherREGEN, AfterDark Roon Network Server. My AfterDark Roon Roc Network Server is not getting an IP address.

I’m not familiar with AfterDark…first time I’ve heard of them. Looks like fancy stuff:

I would definitely reach out to your dealer or retailer to find out what to do next, assuming you’ve performed the obvious troubleshooting steps.

Have you tried rebooting everything in your entire network chain, including the Google fiber ONT/modem?

Yes. I have rebooted everything multiple times. AfterDark says the network is jammed, there isn’t an internet signal from ISP, and the AfterDark Roon Core is not getting an IP address.

Is your Google Fiber working? This implies that Google may be down or having problems with your connection to your home or neighborhood.

I see you are from the Kansas City area. I am in Overland Park. All of the lights are green on the modem and Google fiber router outputs. Maybe I need to unplug and replug the Ethernet cable from the EtherREGEN switch that is connected to the AfterDark Roon Core.

Michael, I’m in OP also. I recently helped set up a friend with some Google Fiber configuration and networking issues. If the modem and router are green, then I recommend unplugging everything after the router and reconnecting one-by-one and see if they are being assigned IP addresses. I’m not aware of your Core PC, so unfortunately don’t know if I can help there.

Will try that. When I troubleshoot the Ethernet network connection it says Ethernet doesn’t have a valid IP configuration.

This seems like the Google router is not assigning an IP address or something else. Is it also possible to sketch out your network from the Google ONT/modem to your device? I had some issues configuring my friend’s in-home Google network using their Google WiFi products, and understanding how your network is configured may help here.

I had a systems administrator friend try to troubleshoot the issue and based on 1st level connections everything is connected and my iPad was verified as communicating with the Roon Core. We did this over the phone. We checked the connection state of the Roon Core at the command prompt. We think it might be the Roon software version but it’s hard to know. My system is as follows: Google modem - Google Router - EtherREGEN Switch input A side - AfterDark Roon Server - EtherREGEN input A side - EtherREGEN output B side - AfterDark Network Bridge (Ethernet to I2S Converter) - Ayon Audio S-5 Network Player/DAC/Preamp. I’m near the corner of 159th and Nall.

Have you tried to bypass the EtherRegen and connect the router directly to the server?

I agree with @Arlen, I would remove the EtherREGEN first and ensure the Core sees the network and receives an IP address. I believe the Google WiFi router only has one extra Ethernet port for any connection downstream, so this may limit the ability to test S-5 streamer unless you use its WiFi capability for a test. Micro Center at 91st and Metcalf, or Best Buy at 119th, sells some TP-Link 5-port Ethernet switches for ~$20 that you can use to connect the streamer to try to isolate if the etherREGEN is an issue or not.

It seems that you shoud be able to connect both the AD server and the Google router to the A ports of the EtherREGEN, and then use its B port to connect the S-5 to the Streamer. The AD bridge may also be a factor and probably should be removed from the audio and network chain initially, then add components one-by-one and see if it breaks anything.

This is what we “network engineers” say when we want to get you off the phone so we can do other things.

OK, start simple work up.

  1. Turn everything off.
  2. Plug in your Google fiber / router and turn it on. Wait for all the lights to go green and show a good connection.
  3. Does the Google supply wifi? Turn on and check if your wifi computer, phone, tablet etc. can access the Internet?
  4. Plug your switch in and let it boot.
  5. Plug a computer into the switch and turn it on. Can it access the Internet?
    Eventually plug all the networking gear in and test. Then, plug in your Roon Core, turn it on, and test. If it’s not working plug a monitor into it and see if there are any errors on boot.

One thing at a time until you find the thing that is broken. Good luck.


I booted each component in the chain individually and checked for the lights at each Ethernet connection. Every device has green lights flashing. Still not able to see my Roon Core on my iPad. I am not able to bypass the EtherREGEN since the AfterDark Roon Server only has one Ethernet connection. I can try to bypass the AfterDark Bridge later today. I might try plugging the Ethernet cable from Router on the EtherREGEN A side into another A side port. This worked when I was using a NAS drive before the AfterDark Server

Michael, are you trying to connect the S-5 directly to the AD server? The S-5 needs to be connected directly to the Google WiFi router via Ethernet cable, or a connected Google mesh device via WiFi.

I recommend going back to what @ipeverywhere states. Connect the AD server with Roon acting as your Core directly to first Google WiFi device acting as your router. using an Ethernet cable. Make sure WiFi is turned on the Google WiFi router, and then connect your iPad to the Google WiFi router via WiFi. Next determine if you can see the Roon Core from your iPad. That isolates that your network is visible to the Core and to the iPad Remote.

Also do you know what version the Roon core is running of Roon? The current version is B931, and the iPad is similar, 931. If these are out of synch, then the iPad Remote may have difficulty connecting to the Core.

Then we can start adding new devices.

1 Like

Guys, thanks so much for your help. I have learned a lot. I connected the AfterDark Server directly to the Google router. All lights are green and flashing. I am not able to connect the AfterDark Server directly to the Ayon S-5 because there is only one Ethernet port on the AfterDark Server. I checked the Roon update log and it was last updated 6 days ago. I disconnected my system on Tuesday. I loaded the Roon app from the App Store so that should take care of any Roon software update issues. I have verified that there is an Ethernet connection on the AfterDark Server. I updated my iPad software yesterday and reboot it a few times. Still not seeing my Roon Core.


Thank you for the update. Can you log into your Google Fiber account and look up and verify the address of the AD server acting as the Core while it is connected to your Google router? Also, is your iPad also assigned an IP address by the Google router? Can you please list these IP addresses here if possible?

Also, as I am not aware of how the AD server operates, are there any special instructions on how Roon is to be activated, logged in, and managed on the server? Just to confirm, the Roon Core was working before you unplugged everything Tuesday, including being seen by the iPad, but now nothing seems to be operating correctly?

Server Network Connection data: IPv4 address:, IPv4 DHCP Server:
IPad IP Address data:, Router data:

I don’t have any info from AfterDark on the Server. On Sunday a week ago everything was working fine. I did check connectivity and communications before unplugging on Tuesday.

Thank you Michael. Everything is on the same subnet, so that is the first step that works. How do you, or did you, access the Core previously? There should be a method to log into Roon and administer it remotely. Do you have another PC, laptop, or Mac where you can install Roon and try to access the Core on the AD server remotely? Is there any other software running on the AD server, or is it acting as a Roon ROCK server?

Robert, I have had the AfterDark Server and Network Bridge running since late September. I always had the iPad controlling the Roon Core remotely. I have had issues with the setup three times but they resolved themselves by turning everything off and on one at a time. The first time I couldn’t fine the Roon Core remotely was resolved by itself (I couldn’t find the Core remotely in the morning and be the evening the same day, it was fine). AfterDark said the network was jammed at that time. I did install Roon Remote on my iPhone this morning and I have the same issue. I will try to install it on my laptop. The AfterDark Server is a Roon Rock Server. Nothing else is running on it.