My Roon Core will not connect

Roon Core Machine

Nucleus + (Rev B), SN: 54B2039818B8

Networking Gear & Setup Details

D-Link DIR-X4860
On Ethernet

Connected Audio Devices

Number of Tracks in Library

Not sure how large, but several hundred albums in my library.

Description of Issue

This problem has occurred maybe 6 times over the past year, but every previous time I’ve been able to get the system running again by restarting the Nucleus or the D-link. When I try to start Roon, the process hangs up at ‘Looking for your Roon Core.’ I’ve tried restarting the Nucleus, the D-link and my Modem, many times to no avail. Have an iMac and iPad connected.

Hey @Bob_Crook,

First off, welcome to the community! I’m so sorry for the delay in getting to your issue, and I thank you for your patience thus far. Digging right into next steps, we’ll want to see if you can access the webUI of your Nucleus.

Here is more info on how to access this:

Please share a screenshot of your webUI if you’re able to access it. If you can’t, are you able to connect your Nucleus to a monitor or TV via HDMI? Please make sure your Nucleus is both online and connected to your network when trying this.

I’ll be monitoring this thread for your reply. :+1:

Hi Ben, I tried hooking the Roon to a TV screen, with the Roon on and connected to the same WiFi as the TV; a “No Signal” message came up. What should we do next? Thanks, Bob

Hey @Bob_Crook,

When you connected the Nucleus to a TV or monitor via HDMI, did you also try connecting it to your network via Ethernet?

Can you confirm the Nucleus is powering on? Are any lights activated when the Nucleus should be on? If not, do you by chance have another power supply cable you can test?

If your Nucleus is turning on, but you can’t see anything pop up on the monitor, you can also check the internal LEDs.

More information about the failure can potentially be found by opening up the unit and taking a look at the LEDs while it is connected to power. Unscrew the bottom panel and look at the LEDs. You will have a Power Switch LED and a Green Motherboard LED.

Hi Ben, Yes the Nucleus is connected to the network via Ethernet and all the lights are functioning in the rear (power, yellow, and green flickering). Both of the internal LED lights are on inside the unit (white and green).

Hey @Bob_Crook,

Thanks for the update! Are any of them flashing in a pattern? Because all LEDs appear to be on, the next step here would be to try a battery reset. We have a video with instructions here:

Note that you will need thermal glue to perform the above. If this doesn’t help, or, you would rather send it to Roon for repair directly, I can follow up via PM to get an RMA started for you. Depending on when you purchased the Nucleus, a service fee may be required for the repair.