My Roon core won't connect with my ipad

Roon Core Machine

I’m running Roon on a MacMini M1 with the Monterey OS (v.12.4)

Networking Gear & Setup Details

Asus mesh

Connected Audio Devices

Wifi using Asus mesh system

Number of Tracks in Library

17,500 tracks

Description of Issue

I recently installed an Asus mesh system, replacing a much older Router + extender system. The signal is vastly improved, but whereas the old network worked fine, in the new set-up either the iPad can’t find the Roon core (which is up and running) or, if I make a minor change to the Roon Core settings, it finds the core but there is a connection failure. This is quite baffling to me.

Also, because of weaknesses in the older router system and the distance between my office and music room, I have had my music library only on an external hard-drive which I move between a MacBook Pro (M1) and the mini. This has always worked perfectly, but now the Mac-mini Roon only registers around 7,000 tracks, while the number as registered on the MacBook pro is 17,500. Should I just reinstall Roon?

Likely the new mesh system uses a different IP address range for wired devices and wireless devices. So essentially creating two networks with core on one and remotes on another. Or if you kept your old router and added in just a mesh connected to it it’s likely running two different wireless networks one on the router and one from the new mesh system. Roon wont work across two without some network configuring. If you connected the new mesh to your existing router ensure it’s in bridge mode.

1 Like

Hi @John_Heritage,

Thank you for reaching out and we’re sorry to hear you’ve been experiencing connectivity difficulties.

A quick glance through your profile from the Admin side shows that your iPad hasn’t synced with Roon Core (as reported), but there may be local network issues with IP address assignment underpinning your problem.

Are you using a network share? If you’re able to provide tech support with a screenshot of your Watched Folders on the Mac Mini, we’ll be better equipped to determine why some local files aren’t appearing on both devices. It’s possible that an IP address for a watched location changed when you set up the new network, and now the local files aren’t available in Roon.

Additionally, would you mind elaborating on your new mesh network? As @CrystalGipsy mentioned, you’ll want to confirm the original router is in bridge mode if you’re using an additional third-party router in the new setup. How many extenders are involved in your setup?

We’ll proceed from there with additional steps. Thank you for your patience in the meantime.