My roon Nucleus occasionally loses the network connection--ethernet

Roon Core Machine

N/A Nucleus

Networking Gear & Setup Details

Hard wired to Asus router

Connected Audio Devices

Connected via Roon Nucleus HDMI output

Number of Tracks in Library

Not that large, I can’t tell you because Nucleus is offline

Description of Issue

I’ve tried turning off and on, disconnecting power and reconnecting, nothing brings it back online. After it sits overnight it mysteriously works again. The nucleus had been playing for about 2 hours today when it happened. Last time was about 3 weeks ago.

Cannot see roon from the PC app nor my android tablet app.

Hi John, welcome to the community, I hope you will hang around and get the answers you need.

Presumably you’ve rebooted the router & swapped out ethernet cables?

Can you successfully ping the nucleus when it appears to be offline?

Have you checked Roon/settings/Audio? - Sometimes the device needs to be re-enabled (No idea why but it happens occasionally).

Oh, and my device does not have Roon settings…I’m playing via the HDMI output.

Yes, tried rebooting router, switching cables, even rebooted cable modem. Cannot ping nucleus successfully.

Oh, and I also use Roon Nucleus to play Tidal.

Have you attached a screen to the nucleus when it is in its odd state and seen what it’s saying then?

1 Like

of course, silly me :roll_eyes:

Not sure how I would attach a screen when it is offline…do you mean via the Nucleus HDMI output?

Yes a TV or monitor

I attached a monitor.

Roon OS 1.0 (build 254) production

It shows it searching for a connection then says
Roon OS UI

It says router not giving DHCP address to the device.

This confuses me since it was online playing for 2 hours before it dropped connection.

I’ve looked in the router software and it is not listed as an attached device. I tried rebooting the router again and it still does not attach.

So I cold booted the routed and Nucleus, now the message is the interface is and it is not giving the message about not getting a DHCP address, but it still is offline and trying to periodically reconnect.

I am going to let it cool overnight and see if it works in the morning. If it does, then I think I have a hardware issue with the Nucleus.

The IP starting with 169.blablabla is one a device creates for itself if there is no timely DHCP server response to a request. The 192.168.x.x now indicates the DHCP server (your router) did its job. Seems you found the culprit.

Edit. You may also want to check the ethernet cable for kinks or damage.

1 Like

Thanks for the info on IP addresses. After I posted the 192xxx IP address the Nucleus kept dropping off the network and retrying to connect, finally going back to a 169xxx address. So after 2 hours of troubleshooting on this board I quit for the night.

I have 12 or more devices on the network at any time, and none of the others ever drop off. After “resting” overnight, the Nucleus is working fine this morning. This is the 4th episode I have had with this unit over the last 6 months. To answer an earlier board question, I was able to check the memory this morning, and it shows appx 3300 tracks.

How do I file a warranty claim to get the hardware fixed? I ordered this from Upscale Audio on 7/12/22, took deliver on 7/20/22.

Serial #54B2038B906B

I’d really try a different ethernet cable prior to start a RMA procedure. Seen this (in relation with DHCP problems) in real life before. Not too much effort testing it.

Plan B): give that Nucleus a static IP address :slight_smile:

1 Like

This is worth a try and there’s nothing to lose if it doesn’t resolve the problem.

Enough with the cables already. I’ve tried different cables, even bypassing the router and going straight to the modem with no router in prior episodes. All that works is resting it overnight.

Is there a link or prior posting as to how to establish a static IP address in the Nucleus?

See here:

Just switch from DCHP to Static IP and put in the same values that were shown when in DHCP mode.

If you can try to exclude (reserve) that address from your router’s DHCP range.

Thanks for that.
Let me ask you this…is it possible I perhaps should have bought the Nucleus Plus? I have a Plus in my other house, I bought the Plus because it drives two rooms and both systems are Roon Ready connections. That unit has been rock solid. I thought the smaller unit here would be fine because it is only one little system utilizing HDMI output. The troublesome unit has now been playing over 4 hours continuously today with no issues. I use this unit all day when we are here. It seems like the times it has frozen up are when I put in a really long playlist. Yesterday it froze in the middle of a 14 hour playlist. The playlists are a combination of Tidal streams and FLAC files on the internal drive. I didn’t realize Roon was considering everything I play part of the “tracks” in memory, I thought it was only the internal files. I was surprised today to see 3300 tracks already after only 5 months of ownership. I’ve installed a 1 TB Western Digital Green SSD in this unit. I put a 4 TB Western Digital Blue in the Plus unit. Perhaps I should have a Nucleus Plus here?

3300 tracks really shouldn’t be a problem for your nucleus, it’s a small library. Once you have tried the static IP address you’ll need to go down the returns/service route.

OK, thanks again. I have manually set the IP in both the Nucleus and my router to match. Please leave this thread open and we will see how it works. Tomorrow morning I’ll try the playlist that locked it up yesterday. Keep your fingers crossed.