My Roon responsiveness has recently gone downhill

Roon Core Machine

NUC-7 specifically NUC7i7BNH with Windows 10

Networking Gear & Setup Details

Ethernet to router, music server also ethernet to router, no VPN

Connected Audio Devices


Number of Tracks in Library

99,000 tracks, 7996 albums

Description of Issue

Roon has been working well since I installed it on the NUC in early 2019. In about the last two months it has gotten very slow to respond. Even more recently the NUC sometimes turns off automatically, but I’ve only observed that happen when it isn’t playing something.

I leave the NUC turned on all the time. When I open the Roon app on my PC (all noted devices are on my desk), it frequently shows “Remote connection - Waiting for Remote Core”. If I actually wait, it may eventually connect after a few minutes, but sometimes it never succeeds before I give up on it. When/if it does connect and I choose “Albums” from the menu, I have to wait anywhere from 30 seconds to 5 minutes before I can make choices from the albums. If I choose a different sort, it’s another similar wait. And so forth. Early on when it started acting like this I could get it back to reasonable operation by rebooting the music server, waiting until it was ready, then rebooting the NUC, waiting a few minutes, trying the Roon app, no success, rebooting the NUC, waiting a few minutes (observing a lot of activity on the music server after the second NUC reboot), trying again, success for the rest of the day. The next morning, back to square one. Note: rebooting the NUC twice without rebooting the music server didn’t help.

I bought a 128GB SSD with the system in 2019 and I’m thinking I may need to increase that drastically. The number of albums I’ve added on the separate music server has increased from around 500GB to 2.3TB presently, so there’s certainly more for the NUC to handle. Does this sound like a reasonable action to address the slowness? I continue to add albums every few days.

I’m not sure at all with what’s happening when the NUC turns itself off. Does anybody have any suggestions? I haven’t updated the Windows 10 since I would have to attach a monitor and keyboard to accomplish that, a nuisance to do. I should probably do that to see if I’m getting Windows diagnostics of some kind and to upgrade it. Lazy, I know, but I’m getting ready to move and have other things to do.

So I assume you are running the NUC with Windows as a headless device. Is there any reason you need to run Windows? If you use the NUC just for Roon I would suggest running Roon ROCK. That way you can make it a turn key device for just Roon.

It’s been so long that I’ve taken a detailed look that I probably didn’t remember the right details. I am using ROCK. If that doesn’t require any Windows interface, then I probably don’t have it. I only remember assembling the NUC, connecting a monitor and keyboard to install the ROCK, and I was done. I’ve done nothing to the NUC since then but turn it off and on.

I said Windows because I looked up on Amazon when I purchased the NUC, and it said Windows 10 interface. I don’t remember doing anything with Windows 10 on this device.

I just finished rebooting everything as described above but also rebooted the router. Wow! Big difference. It’s responding as I expect now. I’ll see how it’s doing tomorrow after resting overnight.

You might also check to make sure it is clean inside NUC, if it gets dusty it could be thermal throttling the CPU?

Can you also confirm what version of Roon you are running?
Have you ever gone to “settings/library” and “cleaned up the library”?
Or to “Settings/setup” and “clear image cache”?
Just to housekeeping suggestions.


After all the restarts etc. the NUC was working fine for about a week, then back to square one with the problem. I think the fan in the NUC has probably either failed or is barely working, as the NUC becomes very hot. I’ve found a video on YouTube to replace the fan and think I will do that soon. A new fan is fairly cheap, only about $12. As a temporary measure until I can get around that, I’m turning off the NUC when not it use, and it definitely works better by doing that, which I think is further evidence that I have a heat problem. I’m moving in about 2 weeks so further action will probably wait until after I’m in the new place. Thanks for the suggestions.

1 Like

Problem solved. Definitely a heat issue. I replaced the fan in the NUC and it is now working really well.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hi @Stephen_Vorenberg,

Wonderful to hear, and please accept our apologies that we did not reach your inquiry in a timely manner to assist. Please create a new topic post if anything comes up and we’ll be more prompt moving forward.