My Roonserver can't find NAS

My network and audio devices are connected like this:

  1. My ROON server (ROCK) and NAS (Synology DS1515+) are connected to the LAN port of the Router (MikroTik RB4011iGS+RM). The WAN port of the Router is connected to the ONU. The internet is running fine. In order to avoid the noise of these devices, they are placed in my storage room.
  2. In the audio room, the network switch (Apple Airport Extreme) has been connected to the router through a Cate7 network cable. My networkplayer is a SOtM sMS-200Ultra NEO, its USB audio output is connected to the DAC (Playback Design PS-8) through the SOtM tx-USBultra interface. After the Roon on iPad connected via WiFi is connected, the DAC is found and connected normally. Through the DSM ( Synology NAS management tool) on the laptop, the link and operation with the NAS are all normal.
    However, when adding local music files to Roon, need add a network share, regardless of the input smb://NASDRIVENAME or enter the IP address of the NAS, Roon shows the network path error.
    Please help me find my NAS in ROON and add music files.

You can’t mount the whole Synology drive that way as far as I know. You need to set up a shared folder in the NAS for your music, which you then ask Roon to mount. In my system, my Synology NAS has a shared folder called music. Within that folder, I have a subfolder FLAC which is where everything that I want Roon to see is stored. I then tell Roon in Settings>Folders to add the FLAC folder of \\\music ( is the fixed IP address of my NAS on my local area network.

Hi, Fernando, Thank you for your reply!
Sorry, I didn’t say enough on the top. I also tried to enter the IP address and the shared folder of my NAS, such as smb://, but ROON still returned: the network path error.

If you can mount it on a Mac or PC, exactly the same URL should work in Roon ROCK.

Thank you, the problem has been solved.
There is a problem with the settings of my NAS.
More than 2,700 albums are now being added to ROON.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.