Mysteriously roon is now unable to connect to one of my HQPlayer/NAA/RoPieeeXL devices

I have a few mac minis running HQPlayer NAA to RoPieeeXL devices, and they’ve always been flawless.

Now, on one of them Roon fails to connect to HQPlayer. (Getting the “Playback failed because Roon couldn’t connect to HQPlayer” message when i try to play.)

I can see the RoPieeeXL’s web management page on the network
I can play Shairpoint to the RoPieeeXL
If I create a zone for that RoPieeeXL without HQPlayer, it works just fine
I can see the RoPieeeXL/DAC endpoint in the HQPlayer list of devices

I’ve restarted Roon, the Pi, HQPlayer, the Mac that HQPlayer lives on, the Mac that Roon lives on.

No joy.

I’ve tried removing that HQPlayer endpoint from Roon and re-adding it.

No joy.

It’s not the Pi, as I was able to test the zone by putting the “bad” zone into the device list on one of the other instances of HQPlayer. When pointed at from a different mac, he offending zone played just fine.

So it seems like it’s an issue with that specific instance of HQPlayer or that mac. (I reinstalled HQPlayer on that mac, and nothing changed. I happen to be running HQP3, and I tested with HQP4, and same behavior.) Corrupted config file?

I’ve compared the settings with the other HQPlayer instances and endpoints, and everything seems exactly the same.

I am stumped.

What am I forgetting to check?

cc’ing @spockfish since he won’t see it in the HQPlayer section, but might have some ideas (was a flip of a coin where to put it)

Firewall? Network control button is not pressed? Does the HQPlayer manage to play standalone without Roon?

Thanks, Jussi.

Network control button is pressed, and HQP can play a file on its own through the RPi/DAC no problem.

Firewall, hmmmm. All the macs can reach each other just fine; no internal firewall. It’s entirely a mac environment. I thought about permissions and file-sharing setup, but I’ve never had an issue before, and nothing’s changed that I can see.

Admittedly, I did swap Pi’s and DACs in this room about a week ago (keeping them together), but it’s worked fine until today. The Pi that was here worked fine here, and the Pi that was in a different room worked fine there. (And the Pi that was here works fine in its new locale.)

Like I said, I can play to it using the Airplay functionality within RoPieeeXL, and I can play to it via Roon if I select the non-HQP zone. So it’s seen on the network just fine.

macOS comes with firewall that is enabled by default. It controls network access of each application separately. When you start HQPlayer first time, it asks whether you want to allow incoming network connections to HQPlayer.

OK, so HQPlayer can access the NAA and DAC. So just Roon is unable to access HQPlayer…

i assume when you ask if HQPlayer can play on its own, all i did was drop a FLAC file into the playlist window and hit PLAY. That worked fine.

Yeah, i’m trying to think of things to uninstall/reinstall.

I could reflash the Pi, but everything else on it seems to work without a hitch.

Might be time to upgrade to HQP4 :wink:

(I only upsample to 192 PCM; not using DSD at all.)

Yeah, so the problem is not with HQPlayer or the RPi.

Including HQPlayer as you’ve tested. So your only problem is Roon not being able to connect to HQPlayer.

yep, seems to be.

I’ve tried to remove and re-map that HQPlayer zone, but that didn’t help.

Once configured, I can’t seem to find a way to tell anything about the zone or the IP address, that all is well. I mean, Roon lets you put ANY IP address in when you’re adding an instance of HQPlayer. It doesn’t care if it’s correct or not.

Yeah, unfortunately it cannot be modified and Roon doesn’t support HQPlayer auto-discovery either. Although the auto-discovery is not supported in HQPlayer v3.

I think i’ll go ahead and upgrade to HQP V4, in any case. I’ll troubleshoot a little more, but it can’t hurt to get the current version!

I am just so mystified as to what changed, or what might be different for that particular instance on that computer.

I tried reinstalling HQPlayer, but it seemed to remember the XML file info. Is there a prefs file that can be deleted so it looks for it again?

THIS is maddening, and that, in combination with my crappy memory, is why I couldn’t troubleshoot what was wrong. But I had an a-ha moment and I figured it out.

Not sure what happened (or how it might have changed), but for some reason I was pointing the Roon HQPlayer IP address at the Pi that has RoPieee on it. But it needs to point to the IP address of the Mac where HQPlayer resides. Duh.

It would be REALLY nice for Roon to tell you what the IP addresses are of the HQPlayer zones, so you can confirm what the others (that are working) are.

Anyway, back in business. Thanks Jussi!


Hesitate to bump this as I have the above problem figured out, but it begs the question…

I have the luxury of some spare mac minis, which I’m using for the sole purpose of running HQPlayer to different RoPieeeXL zones.

It’s certainly nice to be able to do this, as the minis don’t really serve any other purpose at this point. But do I really need a separate mac mini for each instance of HQPlayer NAA? Or can I eliminate them somehow?

I’ve learned so much cool info from this forum, but sometimes I’ll later discover there are better ways of skinning the cat!