MyTek 192 DSD Losing Lock Switching Sample Rates

I’m helping a friend setup Roon on his Windows 7 System and have encountered the same issue where Roon loses connectivity to his MyTek 192 DSD. As others have mentioned, the problem seems to happen when switching resolutions – but haven’t specifically tested that theory.

When the problem happens, restarting Roon seems to get things working again.

The system has been working fine with another media software package for over a year now but my friend would love to switch to Roon if I can get it working for him.

As such, has anyone come across any workarounds for this problem?

Hi @Stephen_Weiss ---- Thank you for the report and my apologies for the troubles here. To help me accurately evaluate this problem your friend is experiencing, may I kindly ask you to please provide the following:

  1. A brief but accurate description of your friend’s current setup as seen here.

  2. Please confirm what driver is being used, ASIO or WASPI.

  3. Please provide screenshot(s) of their audio settings in Roon.

  4. Please verify which formats seem to be having this issue and if playing the same format is yielding the same results.


Hi Eric,

I went to my friend’s house today and played some with the Roon Setup.

Attached are photos of:
1) The Computer / CPU Info
2) Roon Version info
3) ASIO Playback Settings
4) ASIO General Settings

My friend has a MyTek DSD-192 DAC connected via USB.

As for the Symptoms, with Roon Version 1.2 my friend was able to play music via the MyTek ASIO interface but when he switched songs, Roon would stop playing music and would need to be restarted before he could play music again. I don’t know if just switching songs did it or switching songs of different resolution caused the problem.

We installed Roon Version 1.3 and now using MyTek ASIO, no music will play. When configured for ASIO and a song is played, I see the ‘volume bar’ animation to the left of the song title moving, but nothing being is sent to the DAC. After about 5 seconds or so, the animation stops.

My friend wants to use the ASIO Driver as he does for JRiver, but in an effort to get Roon working, I tried the WSAPI Driver.

When I then switched to WSAPI and was able to get music to play… But a few comments:
1) After a fresh reboot, Roon would only play music at the current resolution set on the MyTek. That is, whatever resolution was last played through the MyTek is what any new song would be played at. However, if I closed Roon, started JRiver, started playing any song in JRiver, exited JRiver, then restarted Roon, all songs are played at the correct resolution (as per the display on the MyTek) – everything but DSD128 that played at 176.4. I tried this test a few times to verify and got the same results each time. So I’m guessing that Roon is not initializing something properly in the WSAPI driver???
2) I had to put WSAPI in exclusive mode on for Roon to play music.
3) The WSAPI driver would not detect that the MyTek supported DSD-128. I even tried that option to auto-detect the different DAC Modes supported

Again, my friend wants to use ASIO so I did not take any screen schots of the WSAPI settings.

For reference, JRiver on the same system works fine.

In the meantime, if you any suggestions of what to try next, they would be most welcome.

Kind Regards,

Thanks for all the details @Stephen_Weiss – we are supposed to have a Brooklyn on the way to us, so we should be able to reproduce this if there’s a bug here.

I’m going to check with our developers to see if we can look into this now even without that DAC in house. We should have some feedback in the next few days, and we’ll do whatever we can to get ASIO working here.

Sorry for the trouble here, and thanks for your patience.

1 Like

Hi Mike,
Thanks for your message and looking into this further If your developers use such, I can install DebugView and get a capture if that would be helpful. Also, if any of the developers are in New York and would find it useful to see the system in person (or even through remote support session), I’m sure my friend would be open to that.
Kind Regards,

Hi @Stephen_Weiss ----- Thank you for following up with us and my apologies for the long wait here. I wanted to touch base to see if your friend is still experiencing this issue with their Mytek 192 DSD.

Looking forward to your feedback!

Hi Eric,
Thanks for the follow-up. My friend is still experiencing the issue.

Hi @Stephen_Weiss ----- Thank you for the follow up and my apologies for the delayed response.

I had a chance to meet with my team yesterday to discuss this behavior your friend is experiencing when using their MyTek 192 DSD DAC. The ASIO driver should be working and I would kindly like to ask your friend to please test with the following settings engaged:

  1. Try using the resync delay feature found in “device setup”.

  2. Try setting the “max sample rate (PCM)” to 192.

  3. Please give DoP a try.

Looking forward to your feedback!