Mytek 192 DSD OS X El Capitan

I love Roon. You have the best looking UI, the best ease of use. All great. However I came across a good deal on a Mytek 192 DSD DAC. I am running OS X El Capitan. Guess what? I can’t seem to engage DSD at all! Roon sees the Mytek but reports DSD 64 and not 128. During playback it always converts to PCM. I’ve fiddled with the settings but still no luck.

My connection is via Firewire and the Mytek Firewire driver.

I’ve switched to Audirvana Plus just to be able to make good use of the Mytek. It has been a huge step backwards in terms of interface and usability. Getting DSD playback though was dead simple under it.

What can I try?

Hi John,

I found this. Don’t know if it helps answer your question.

Cheers, Greg

Hello Greg,

Thank you. I too had seen that. However it does not address/resolve the issue. It is too bad as I really liked the Roon UI and ease of use over Audirvana.

This would seem to be a quirk of Roon, since I have no problem upsampling to DSD128 using Roon -> HQPlayer -> FireWire -> Mytek Stereo192-DSD.

I can also upsample PCM to DSD128 using the latest version of Audirvana Plus (, again via FireWire only.

I couldn’t get Roon to show DSD128 as a supported rate when I tried to set up to play directly from Roon to “Mytek_FireWire”. I suspect an issue with Mytek’s FW driver.