Mytek Brooklyn Dac+ Unstable with Roon

Roon crashes when Brooklyn Dac + Wasapi is playing.
Sometimes Roon will show as if a track is playing but no signal would reach the Dac.
When Asio is playing; Dsd and standard cd tracks sound good however all 24 bit files sound distortred.

System: desktop - windows 7 64 bit - Roon software - Latest drivers and firmware available on Mytek website on this day ( 18-4-2018) have been installed properly - Synology Nas drive; holds 4 tb of Dsd and pcm high res and cd quality music

Robert,

Is your MQA decoder disabled on the Brooklyn? I am running into the same problem with distortion on 24-bit files but only when the MQA decoder is disabled. As soon as I re-enable MQA things sound better.

I’ve been upsampling to DSD128 as a work around.

Currently running Ubuntu with a patched kernel for native DSD but in testing I get the distortion with OS X, Windows, and Linux.

Edit: I haven’t tried WASAPI with Windows so I can’t speak to the crashes.

Forgetting Roon for the moment, can you use another player on your Windows machine and see if the behaviour is the same? This sounds more like a driver problem rather than a Roon problem.

Matt, Anthony
I was getting an annoying and continuous “tick ” with the optical input (tv) ; after trial and error I found that disabling Mqa was the solution to this problem.

The Dac worked fine for weeks with both Jriver and Roon; then for no obvious reasons i started getting all sort of problems - (ie. humming in the left channel ( both headphones and speakers), the Ticking mentioned above, then came “ popping “ in both optical and USB and the cherry on the top was the distortion on all 24 bit files .

Mytek asked me to remove the jumpers and to update the firmware, so I did but that was a futile waste of time, so the dealer sent me a new Dac, it came with the latest firmware preinstalled.

After trying every possible scenario I gave up on Jriver and focused on Roon, where only the Brooklyn + Wasapi seemed to solve the problems, this lasted 10 minutes only. After that Roon crashed and after restarting my PC, wasapi became unstable , it worked for a track, then the sound disappeared during the next one ; then a message popped up at the bottom of the screen “ Transport: failed to initialize the audio device”

As mentioned , with Asio, Dsd and cd resolution are fine , but 24 bits files are distorted.

In the past I had the Mytek 192 Dsd and it worked perfectly. Dac+ has been a headache.

Anthony : I agree with you , it seems a Mytek problem (driver or whatever), however Mytek are supposed to be Roon compatible - and since replacing the hardware did not solve the problems, we either have a fundamentally flawed product or as you said it’s a driver issue. In any case I had to come here and try to find a solution myself as I have no other alternatives unless my dealer agrees to unwind the transaction.

I believe that Roon (or any other audio player) only talks to the driver on whatever endpoint it is playing on. As the issues seem to affect all players on your hardware it is probably a DAC (hardware or software) or OS driver issue. I wouldn’t rule out issues with the OS and PC hardware either. Is it possible to get your DAC checked out by your dealer, or use it with another PC?

Unless you can achieve a stable platform on which to drive a DAC, it is likely that any DAC you buy (if you get a refund on the Mytek) could suffer similar issues. What is the spec of the PC you are using? Given that you are using Win 7, is it an older one?

The only time I have had those symptoms in Roon (Playing but no sound, and transport failed messages) is when there is a problem with the endpoint (sonos and bluesound devices at the time).

Its a customized pc built to play music running on windows 7 64 which is known to be a very stable platform - at least for my old Mytek 192 Dac - and auralic Vega I had boroughed from a friend.

Mytek states that dac+ is compatible with windows 7 - Moreover other people complaining about performance in this forum and other places are using different platforms and operating systems - the only constant across all platforms is the Dac+ ; so it is safe to conclude that the Dac+ is guilty.

I’m sorry to hear about your problems with the Brooklyn+. I’ve had one since February and haven’t had any issues. I think the only significant difference between our setups is that I’m running it on a Windows 10/64bit machine.

Just some things to consider based on what you’ve said so far:

  1. Try it on a windows 10 machine
  2. Uninstall the 192 DSD DAC driver and the Brooklyn+ driver; reinstall the Brooklyn+ driver only

Thank you all for the suggestions - I already did remove the old drivers as suggested a while ago.

As for windows 10 - other people with windows 10 on this forum are having similar issues; so buying a license for windows 10 is not guaranteed to solve the problem - then someone will suggest I invest in a new power cable.
It’s an expensive piece of electronics; a consumer product that either works or it doesn’t - either it is compatible with windows 7 or it is not.

Worth mentioning that the Dac+ i initially purchased was making a weird “tick” only when using optical input . Here there is no OS to blame nor drivers to change, only a new LG Oled TV.

By trial and error I found out that disabling MQA solved the problem - then in order to solve the USB issues , someone suggested I enable MQA; so what about the remaining filters; aren’t we supposed to have access to these as well? What a quagmire

Hello @Robert_Nasr,

If you are using the “WASAPI” output to the device instead of the “ASIO” output, you actually are not using the Mytek driver at all. You are using the Windows standard drivers to talk to the Device using the UAC2 protocol. Just thought I’d mention as an extra data point.

To troubleshoot, diagnose, and fix this issue for you, we’re going to need to separate the components of your system in order to narrow down what is at the root of this behavior. The best way to accomplish this will be to try using the Brooklyn DAC+ on another computer to see how it behaves there. Another possible culprit for the behavior you are seeing could be the interconnect between the computer and the device. It could be a poor connection to the USB outputs on your computer, a broken USB port, a bad USB cable, or a malfunctioning USB port on the Brooklyn DAC+. Once again, the only way to find out is to swap the cable and use it on a different computer.

This is outside the realm of Roon functioning with the Brooklyn DAC+, however I have seen the behavior you are describing with the optical cable as well. In my case, replacing the optical cable and ensuring that there are no sharp bends in the cable as well as securing the connections on both ends solved the issue for me.

-John

Thank you John - the system as is, worked perfectly last week with Auralic Vega - I believe I mentioned that already many times - also as previously mentioned the reason I used wasapi was because Asio didn’t work :

No doubt your advice is coming from a good place ; I am new here but I noticed that there is a tendency among people to doubt everything , everyone and a thoroughly tested system before even considering that the new piece of equipment might be the problem.

In my case the first Dac+ I received from the shop was defective; so they sent me another one, subject of this conversation.

in any case wasapi worked only for 10 minutes ——- fast forward someone in the thread mentioned that I should ENABLE the Mqa filter as this would SOLVE the problem with Asio ; indeed it did ; however when I changed the input to optical I had to disable Mqa to avoid the weird noises. Also with this solution I cannot use the other filters at all.

To conclude; Anyone having problems with the Brooklyn Dac+; it is almost surely the Dac itself ; especially if you have no logical reason to doubt your system.

SOLUTION : Enable Mqa when playing via USB -

For Roon, choose ASIO, but you must be content with the MQA filter and forget about using other filters, including the popular FRMP and SRMP.

From my end I’m done with it - it’s going back home.

Thank you John and all for your contribution
Best
R

Hi Robert,
glad that you have decided on a way forward and it seems unfortunate that Mytek are releasing products of that quality at the prices they are charging.

With regard to the quote above, I think you are being a little unfair to Roon support and those that choose to help people with issues in this community. Roon is used by people with a wide variety of knowledge of computers, networking and computer audio. This extends all the way from seasoned experienced IT professionals and enthusiasts, down to quite frankly, the sort of person that shouldn’t be let anywhere near a computer. When a problem is posted, there is very often a huge amount of information missing that someone needs to rule out various issues. Take your first post for example:

No information on the PC hardware
No information on how your system is connected together (wired, wireless etc)
No indication at that point that you had ‘a thoroughly tested system’.

Of course questions are going to be asked in these circumstances to uncover the facts and assist you. I work in IT and a huge amount of time is wasted by people making assumptions based on partial information and jumping to incorrect conclusions as a result. Step by step diagnosis and verification of individual components through substitution is often the only way forward, time consuming though it may be.

Regarding your comment on the stability of WIN 7, I have a good example of a modern laptop with a buggy Win 7 installation. My brand new work laptop has actually had WIN 7 put on it (as that is our standard company OS build). It glitches like a good 'un because for some reason they have not properly updated the graphics drivers! My experience of Windows PCs over the years has been that they are always happiest running on hardware that is of similar vintage to the OS. Running new OS on old hardware generally has optimisation issues with variable driver support. Running an older OS on newer hardware runs into driver issues. Sometimes these get fixed and sometimes not.

The suggestion to try WIn10 was very valid given the issues you have. WIN 10 licenses are not expensive and you can try it for 30 days before needing to activate and pay for a license anyway I think. If you have a gaming PC you will understand the mess that Windows can get itself into with drivers, especially realtime ones such as graphics and audio. Sometimes a complete reinstall from scratch is the best way forward in those circumstances.

Please don’t take this post the wrong way, I am not having a go, just trying to explain why so many questions are asked and assumptions challenged. :slight_smile:

1 Like

Message well received :slightly_smiling_face:

Sorry I didn’t want to sound mean ; but in my mind I am here because I am having serious problems with a new device and it seems that other people are struggling too and trying to seek help on the forum -

After I stated that my system has been consistently stable and that last week an Auralic Dac was connected and running properly with all accessories and associated cables ; I received recommendations to check the cables and update windows - now I understand why people came with such recommendations - for me stating that my system was running perfectly for years with the old Mytek Dac; and recently an Auralic Dac ; is a statement that cables are good - pc is working fine and that the new link in the chain is the weakest. In this particular case I was right ( as I have explained in my previous message).

Cheers
R

1 Like

Hello @Robert_Nasr,

I completely understand your frustration. As an audio enthusiast myself, I too have experienced the sometimes hair-pulling sensation that results from getting excited about bringing a piece of gear home, it not working the way it was intended too, and the resulting laborious troubleshooting process that can feel like further punishment when you just wanted a new way to experience and enjoy your music.

Considering we have many users using the Mytek Brooklyn DAC+ on Windows 7 without having to jump through the hoops that you were to get playback working correctly, I wanted to isolate the device from your computer in order to be able to more finely pinpoint if the issue was in the signal path or in the device itself. However, if you feel as though the device did not meet your expectations insofar as it working correctly in the setup you have, that’s all that really matters here. It’s understandable that you’d expect the Mytek to work in your system when the Auralic is running fine.

I hope you’re able to find a device that works in your setup without issue so you can get back to enjoying Roon and your music! Let me know if there’s anything else I can do to help!

-John