Mytek Brooklyn sometimes can't lock onto sample rate or format changes reliably

This only happens when I am quickly switching between sounds formats – like trying to compare a MQA album vs a hi-res version or applying and removing up-sampling DSP in Roon 1.3.

I can’t determine a pattern that triggers it apart from frequent switching tends to make it happen more often. But if I try, I am fairly sure I can get it to occur within about 10 minutes.

What happens is the digital display on the Brooklyn remains at the previous files type but it plays extremely distorted shrieky music that has me scrambling to pause to turn down the volume as quickly as possible to avoid damaging speakers and ears.

It seems like when this happens I have to power cycle the Brooklyn to get it sounding right again. It may have recovered on it’s own had I left it paused long enough for it to catch it’s breath before playing, but I felt safer performing the power cycle.

Has anyone else encountered this? I am not sure if the problem is is caused by the microRendu or the Brooklyn or a combination of both. Your feedback would be helpful before I escalate this to Mytek or Sonore.

My setup is:

Roon Core (happened when using Synology NAS as well as sT i7; music library on NAS) > microRendu > Brooklyn > Amp or Headphones

All software and firmware is the latest available for each element except for the Brooklyn which is running one version older than the latest (the latest only fixes a graphical glitch).

Thanks for any feedback you can provide!

@Matthew_Clegg - since you have a similar setup of mR + Brooklyn, have you faced this?

I haven’t, but i haven’t had the brooklyn in my setup long.

I will see if I can re-create sometime today.

thanks. just keep your volume very low if you are trying to make this happen. the noise is disturbing and sounds like it could be damaging even at modest levels.

I’ve had my Brooklyn since last summer and have not had the experience you describe. However I tend to play albums from start to finish. I rarely do any shuffling around, I don’t believe I’ve even created a playlist ever. My setup is Roon Core running on a dedicated (Roon only) 2015 MacMini fully loaded. My music library sits on a Synology 415Play. The Brooklyn is directly connected to the MacMini via USB2. MacMini and Synology are hard wired via a router. My Roon remotes are on wireless MacBookPros. All works just fine.

Hi @rayski – your feedback on this community is partly what encouraged me to go ahead with the Brooklyn - thanks!

I only managed to buy it in December and it has been a slow process of finding the time to enjoy it and waiting for various other equipment to come in. When I do find the time to listen, I am very satisfied. :blush:

When I am listening for enjoyment, I have not come across the problem I described – I also have the timing set at 500ms between format changes to zone in Roon. However, I think that when a user manually switches songs or applies dsp changes the timeout is bypassed or interfered with which is why I may be facing this problem. From your description, it does not seem that you either of the above enough to be able to confirm if your experience is same/different than mine. While you are using the macmini instead of the mR, I don’t think that would make a significant difference in this case unless the Roon ridge on the macmini adds its own delay…

Adeeb I’ve been away a for a bit and unable to check my timing settings. Later this week when I get a chance I’ll check my settings and provide them for you. I’ll also try hitting the Brooklyn with track switches using different formats and resolutions to see what happens. But it could take a few days to try this.

1 Like

Hi Adeeb. I ran some tests today for you.

First I have the timing (ReSync Delay) set to 0 seconds. I then did hard track switching calling up different albums of different formats & resolutions. Often playing a track for no more than 30 seconds. I switched between 16/44, MQA, 24/96, 24/192, 24/176 and DSD64 going back and forth between, mixing it up. In every instance the Brooklyn reported the resolution before the music even started and then played it without a hiccup.

I’m really not sure how to check if Roon Bridge is adding any hidden delays for the MacMini or if the MacMini itself adds something. What I can say is that I didn’t see any noticeable delays beyond what you’d expect. Example while playing one track I hit Play for the next track, I’ll immediately see the Brooklyn register the new resolution and very shortly after the track starts playing. How shortly, too short to measure, certainly less than a second.

I hope this helps. If there are other tests you’d like me to try let me know.

thank you for trying – greatly appreciated!
did you try enabling and disabling or changing the settings of DSP upscaling while playing music?

Adeeb - I tried doing sample rate conversion during mid-play. There is a slight pause as Roon sets up, things come back on and I see the chosen sample rate conversion in the Brooklyn. Here is the conversion I did:

Everything worked as expected. Brooklyn even confirming what Roon is saying.

Note that I tried a few different upsamplings besides DSD64. All worked as expected.

thanks for trying this out. i’ll raise this with mytek and see what they say.

Update: It seems like the latest firmware that Mytek released a couple of days back for the Brooklyn DAC seems to have fixed this issue for me.

From the release notes:

v2.32 / 2017-04-27

  • fixed: DC offset on Linux
  • fixed: Meters in DSD mode

v2.31 / 2017-04-20

  • reversion to old MQA indication (added magenta logo for MQA Core)

v2.30 / 2017-04-12

  • fixed: Nec receiver fixed.
  • improved: larger fonts on simple screen added
  • improved: new MQA decoder with new communication scheme
  • fixed: improved USB frequency switching

Brooklyn owners can download it here:

hi there,
i wonder if the update had worked for you?!
I own a Manhattan 2 two months now. With the latest update. But i experience the error occur sometimes now and then. Its quiet annoying. I have the restart/reboot the DAC/pre-amplefier.

I have the original Brooklyn and as of firmware v2.3 onwards, I do not have this problem.

Have you tried to investigate upstream (cable, source, etc?). Also, do you use DSP Sample Rate Conversion to output to the max rate and specific format supported by the Manhattan II? If not, it might be worth the experiment to see if that does in fact eliminate the errors you are referring to.

Also, I still have problems with streaming (i.e. not added to my Roon library) tracks from Tidal. But this is a Roon/Tidal issue and they are working on it I believe. I am only mentioning this here in case it overlaps with what you are reporting as errors.

Otherwise, I would report this to Mytek. My impression is that they investigate such issues quickly.