Mytek Stereo192-DSD-DAC ASIO Driver Device Fail

I am having trouble connecting the audio output to Mytek USB DAC ASIO. I get a Device Initialization Failed immediately when I try to enable the output. I have got the latest USB driver from Mytek with no help. I have a Lynx E22 sound card that permits ASIO. I see a Mytek USB DAC WDM driver under audio devices in Windows 10 device manager and other drivers. I disabled the other drivers but it didn’t solve the issue.

Any Ideas?

Hi @Andrew_Schuplin,

Is your Mytek powered on and has the correct input selected when you try to enable it?
Does the DAC work in apps outside of Roon using the same machine that’s hosting the Roon Core?


After experiencing the problem and sending this post I was able to enable the Mytek ASIO driver. The main thing I did was disable all of the other sound drivers except the Mytek driver. I then disabled the Mytek WDM driver. When I tried the Mytek ASIO again it enabled. I tried to get it back in a bad state and I couldn’t. Its been working fine since.

1 Like

Hi @Andrew_Schuplin,

Glad to hear that the issue has been resolved. I will be leaving your thread open just in case it re-occurs (hopefully it won’t).

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.