NAA Version 356 Can't assign requested address


#1

Hi All

Anyone else run into this issue with the new NAA Version 356 on Mac OS?

[/Users/networkaudiod-356/networkaudiod] (681): clSocket::SetOption(): setsockopt(): Can’t assign requested address

I can run NAA 354 with no issue.

Thanks!


#2

I have the same issue and I was told it because it was trying to allocate an IPV6 address from your router. However, I don’t know how to disable such behavior so I have to use 354.


(Jussi Laako (Signalyst)) #3

IPv6 doesn’t need address from router, as long as it is left to do auto-configuration it comes up with reasonable link-local IPv6 address. So if you look at output from “ifconfig” you should see IPv4 and IPv6 address on your primary ethernet interface.

Alternatively you can assign fixed local IPv6 addresses for both ends, like for example fc00::a and fc00::b (64-bit prefix).

In any case, you can set environment variable NETWORKAUDIOD_IPV6=0 to disable IPv6 support which essentially reverts you back to how 3.5.4 works.


#4

Thanks for your reply (and the great product by the way). I actually googled and tried couple ways before post here,

I tried both automatically and local only for my WIFI IPV6 settings, both are ending up with same “can’t assign requested address” error.

And I tried disable IPV6 variable like below, but get another error instead.

kmacbook-pro:networkaudiod $ export NETWORKAUDIOD_IPV6=0

kmacbook-pro:networkaudiod $ ./networkaudiod

[./networkaudiod] (1751): networkaudiod Copyright © 2011-2019 Jussi Laako / Signalyst. All rights reserved.

[./networkaudiod] (1751): clSocket::SetOption(): setsockopt(): Invalid argument

[./networkaudiod] (1751): clSocket::SetOption(): setsockopt(): Invalid argument

[./networkaudiod] (1751): clSocket::SetOption(): setsockopt(): Invalid argument

[./networkaudiod] (1751): clSocket::SetOption(): setsockopt(): Invalid argument


#5

and here is my NIC IPv6 setup.


(Jussi Laako (Signalyst)) #6

This was regression introduced in 3.5.6, I have now fixed it and built new package 3.5.6.1 for Mac.


#7

Thanks Jussi, it is cool and I don’t see that error any more. BTW, maybe a off-topic question, I tried all filters which above “ASDM7”, two 256-fs and one 512-fs, my HQ Player keeps flashing but does not playing. Other filters including ASDM7 work as expected. Does that mean my DAC not accept the DSD 256 and higher rate? I am currently using an iFi micro iDSD BL on a macbook pro. iFi 5.30c firmware downgrade the DSD support from DSD 512 to DSD 256 but adding MQA support as trade-off. However, I can only get DSD 128 or lower filters working with it.


(Jussi Laako (Signalyst)) #8

Yes, you need 5.2 firmware to get DSD256 working on macOS. Because they removed support for highest PCM and DSD rates along with S/PDIF output support to make space for MQA.


#9

Thanks for the reply, really appreciate it.