NAD C658 & Ci580 wont play Tidal MQA or high res content

Roon Core Machine

Vortexbox/Sonicorbiter i5/Linux 4.13.16-211.fc25x86_64 Roon build 831

Networking Gear & Setup Details

Wired network with technicolor router and Google nest wifi. Netgear unmanaged swithc in loft.

Connected Audio Devices

Auralic Aries G1 USB to Meridian Ultradac (wifi)
NAD Ci580 mk1 wired ethernet
NAD C658 Wired ethernet
Bluesound Node 2 wired ethernet
Google chromecast wifi
Apple Homepod wifi
SKy boxes etc Airplay wifi

Number of Tracks in Library


Description of Issue

No playback via NAD devices (Ci580 and C658) of Tidal MQA content (non mqa is fine) and some high res library content too. Roon displays ‘audio file is loading slowly’ then gives up. No path shown.
Auralic plays tidal mqa happily.
Any advice on best set up for NAD devices? I have them with core decoder enabled and nad set to decode and render, have tried render only to no avail.

If you use any Roon DSP, then leave Core Decode on. Otherwise you can leave it off.

Your NAD should be set to decoder and renderer.

As for the error you get, this is usually an indication of networking issues.

I only use mono under dsp as far as i recall, naturally mono is to be found in the ‘convolution engine’ which is intuitive. I use mono as its a ceiling speaker system with only one speaker in some rooms.
I find networking issues to be an often used reason for errors in Roon, yet my Auralic Aries (until recently always wired) never misses a beat regardless of content yet is on the same network as the NAD devices. Furthermore video passes round the network without incident and uses much more bandwith.
As noted the NAD units are indeed set as decoder and renderer.

Hey @jeremy_davies,

Thanks so much for letting us know of the issue you ran into — we’re very sorry we took this long to get back to you…it’s not hard to imagine how annoying it can be to start a listening session and be stopped by an error :pensive:

Just for a little context, it’s important to know that Roon relies on network stability a lot more than just a streaming service. The Core performs intensive operations (from downloading and updating metadata, artwork, to any filters you might be using) and needs strong connections for a seamless playback. If that’s not possible, rather than altering the stream, Roon will stop it.

This being said, I wonder, have you ever seen our Networking Best Practices advice? It’s a great starting point if you want to make the most out of Roon.

Hi Rebeka,
Thanks for getting back to me. It perhaps bears repeating that most of my network is wired and the NAD devices that wont play mqa and high res content (Ci580 and C658) are both connected to the wired network. My Auralic Aries G1 is stable both wired and wireless and both my Meridian endpoints (wired) are fine too.
In view of this i struggle to see how network issues can be entirely the root cause of my issues when several devices are unaffected?

Hi @jeremy_davies ,

Are you using the latest firmware on the NAD devices? Is local MQA also affected? You can download local MQA tracks from the 2L Test Bench (right-click on the file size → save as).

Hi Noris,
Thanks for getting back to me. Do you know how to update the NAD firmware, the only way i know is via the bluesound app and i have not checked it for a while so will give it a go tomorrow. Will also try the local mqa test as you suggest. Thanks.

1 Like

Follwoing update via the bluesound app i can play most high res (not tried every format) content but still no mqa.
I have tried downloading the 2l testbench samples but dont get a save as option on right click, only save as link.

Hi @jeremy_davies ,

You would need to right-click the file size aspect, that links to a .FLAC file and you should be able to save it that way.

That doesnt show as an option for me:

Hi @jeremy_davies ,

If you click “save link as”, does that download a FLAC file for you? We may be seeing different options as I’m using Windows while you’re using Mac.

Hi Noris,

Thank you, that worked. Perhaps i should have thought of that!
In any case it wont play on the NAD Ci580, not tried the C658 as thats tough to test right now.

Hi Noris,
After the update to 1.8 both NAD Ci580 and C658 play Tidal mqa content, which they did not before. Not tested the download but since i only listen to mqa content on tiday anyway its far from critical.
Thanks for the update.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.