Naim Uniti Nova disappears from Roon mid-song

I am using Roon in 2 separate locations with one being the ‘mother’ (based on a NAS) and the other just for playback based on a Mac mini (ie I don’t add anything to it). The way I update them is that I use 2 drives: One is attached to the NAS, getting copies of any added music as well as Roon Database Backup file and the other sits on the playback Mac mini. I swap the HDs a couple of times a year to keep my 'playback Mac mini current with my latest additions.

I basically disable the Drive, unplug it, plug in the updated one, and point Roon to it. However, this does not carry my Database info (preferences, etc…) plus it scrambles the order of the albums on the display. For example, if I select ‘Sort by Date Added’, this does not reflect how I have added them on the original drive.

I could not find how to inform Roon where to look for the Database files. I think the problem is there. Roon probably does not see it, as it is in a different place or name it is expecting, and builds its own again, in a different fashion.

Any help on how to do this in future, and, if possible, fix the current setup on my playback mini would be great.

Thank you

Here’s how to find Roon’s library. This is where it must reside. You can’t (easily) change the location.

To transport a library from one machine to another, you should use Roon’s Backup/Restore.

Thank you.

So in order to get this right (database as per old system), I should perform a Restore on the backup after plugging in the new drive ?

My main Roon installation was backing up on a folder called Roon Database Backup (on the root directory). If I click on the folder, I get a bunch of folders including ‘Roon’, ‘Roonbackups’, ‘latest’ , a couple of folders with weird names (series of numbers and letters) etc.
So which folder should I point the restore function to? The main Roon Database Backup folder?

With the appropriate modifications to fit your particular circumstance, you can follow this guide.

1 Like

That was perfect :slight_smile: Thank you very much. I’ve got my Playback Mac mini looking just like my main rig one.

Actually, that didn’t work :frowning:

When restoring the database, I get the album display as supposed to be (with last ones added really showing last ones added), but a day later, I lost everything except Tidal, ie everything except for Tidal disappeared from the album display. Poking around shows that the new drive is not ‘seen’ by Roon. So adding it on the list of Storage prompts the system to reload everything … which ends up in alphabetical order in the order of the folders on the drive (I have separate folders for hi-res, normal and mp3).

I thought maybe this is because some time elapsed. So re-installed the database one more time and as soon as it was done, I added the external HD as a storage. Again, same thing happened and it reloaded the files in alphabetical order.

I followed pretty much what the guide on the link says, but although I get everything back, my library is ordered in the order of the files on the USB drive.

Does anyone have any clues?

Huh? Files aren’t in any specific order on a drive. They’re displayed in the way you specify.


I appreciate your help, but the ‘date added’ is the date (and order) Roon added them to its local system not the date (or order) in I have added them to the main system on the NAS. All titles show they were added on 28 June 2021, regardless when they were actually added.

I just saw from your note the Track Import date options which I wasn’t aware of. I just switched it - it was set on date of import.

Now I guess it has to rebuild the database or the view

Probably just the view.

Next time, make sure all your storage is connected when/if you do another Restore.

No difference - I despair. Still shows everything as 28 June AND lost sight of the Naim Nova.

and that doesn’t work - the drive was connected. However, when I do a restore from the old database, it doesn’t show up in Roon. It’s the backup of the NAS, which is not tagged as a storage folder on Roon in my main system

Ok - after about 24 hrs of working, my music is now appearing in the real Date Added order !!

Now I have to figure out why it keeps losing sight of the Naim Uniti Nova, necessitating a reboot of the Nova for Roon to see it again.

1 Like

You’ve been there before.

I have, this is a bit different.The patching is still as solved last time. It’s Roon ‘stopping’ to see the Nova suddenly - sometimes mid-play. The solution is to reboot the Nova (unplug/plug back). Annoying.
I think I need to change the core. It’s a 2012 Mac mini which is probably underpowered for iOS 10.16 - might go to a NUC this time.

I doubt that’s the problem.


Hey @Cemil,

Thanks so much for enagaging on the Roon community and working through keeping both of your Cores synchronized. I’m glad you’ve found a solution to that :partying_face:

A big thank you to all who helped :pray:

I was wondering if you could check your Naim Uniti Nova for a firmware update. If there is one available, can you please update it?

Would there be a chance to reset your router ?

Hi Rebeka,

Thank you for coming back. My Nova has the latest firmware. It sits in a second location (holiday home) and I updated it when I got there, after a long absence.

I think part of my problem is the network setup - it’s a bit of a mess with a mix of wired and wifi networks (4 wifi !). Still doesn’t explain the loss of connection between the Naim and Roon as they are both connected via ethernet through the same box, but something is happening to lose that connection which needs to be reset by unplugging / replugging the Naim. It might be that my old Mac Mini is overloaded and ‘loses’ it briefly which ends up with Roon dropping the Nova.

I am unfortunately no longer in my holiday home, but my first task when I get back (in a couple of months, Covid permitting) is to clean up my network topology. I’ll probably need to replace the wifi hubs with a mesh system.

I’ll get back to this topic once I do that, either to report that all is fixed or to get some more advice. If I need to replace the Mac, I will probably go the NUC route.

1 Like

If my Naim Atom dissapears then I know I have a network issue, quick reboot of my mesh network device master and all comes back. I’ve only had to switch the Atom on and off twice in its lifetime.
So your thoughts about it being a network issue make sense to me.

1 Like

Hey @Cemil,

I appreciate your prompt reply. Thanks so much for confirming what steps you’ve taken and your concerns about the network connection. It does sound like sorting out the cables and wifi connections might improve this, just @ged_hickman1 has proved works for them (thanks for chiming in).

Whenever you get a chance to return, please, let us know :nerd_face:

In the meantime, I hope you’re using Roon at your primary home :houses: :musical_note: