Naim Uniti Star - Audio device refused to switch input to Roon

Core Machine (Operating system/System info/Roon build number)

Windows 10 / Roon Version 1.6

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired LAN Connection / TP Link Router and TP Link Ethernet Switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

NAIM Uniti Star connected over LAN Hardwired Ethernet Cable

Description Of Issue

Every once in a while my Roon Core does not connect to my Naim Uniti Star and displays the message “Audio device refused to switch input to Roon.”. The only way to get this working again is to powercycle my Naim Uniti Star

I have tried to powercycle my router, and my roon core PC but the problem still exists till the time I powercycle my Naim Uniti Star unit.

At all points my Uniti Star is connected to my network (I can access the Uniti Star’s web settings page by typing in the internal IP address) and so it is not a uniti star LAN connection problem per se.

Sounds like the Star has a problem, my Atom works every time never had a problem.

I have had this a few times myself with my Atom since 1.6 never had before.

Had this once with my Star but followed casting from iplayer.

Hi @Poseidon,

Apologies for the delay in response here. Can you please let me know some more information here:

  • What is the exact model of your TP-Link router and switch?
  • How often would you say that this issue occurs, once a week? More? Less?
  • Is the Uniti Star using the newest firmware?
  • Right before this issue occurred, were you streaming audio to the Star using another app?
  • Can you note the exact local time in your country when this issue occurs next? E.g. 3:31PM on 5/9/19?


@noris I keep getting a similar error with my Naim Uniti Atom. Its just been updated to their latest firmware and I get an error of Roon has stopped playback as device switched input. Nothing was changed on the device itself. It seems to do this when first powered on from Roon then it plays for a short while then stops and gives the error.

Hi @CrystalGipsy,

  • Has this issue started occurring only after updating the firmware?
  • Does this behavior occur regardless of the source file (Streaming/Local) or sample rate in use?
  • How long does it play for before you experience this error (approximate minutes/hours)?
  • Have you been in touch with Naim regarding this issue yet?

– Noris

This error after the update but I had the refused switching one before.

Resolutions have been 44.1/16 for the two times its occured as thats the only time it’s been played from an off state. I think in these cases they where not local content can’t vouch for other times.

Not long into the song perhaps 10-20 secs.

Not contacted Naim as yet.

Hi @CrystalGipsy,

Just to be clear here, this issue hasn’t occurred yet when the Atom was already powered on and has only occurred when the Atom was exiting the standby state?

Can you let me know the exact local time + date of when this issue next occurs? There may or may not be an interesting trace in the logs, but won’t hurt to check.

– Noris

I sure will. It seemed to be fine this morning.

1 Like

Hi @noris,

Firstly apologies for not getting back to you since I was traveling quite a bit recently.

Secondly, I have some good news. Due to another issue I had to replace my TP Link Router (which kept dropping the WAN connection intermittently although the LAN connection stayed stable interestingly). After replacing the router I am pleased to inform you that the problem seems to have been rectified.

I no longer get that error message and the Uniti Star lights up the minute I start giving it a command through Roon.

So for any of you folks out there who experience the same problem, try swapping your router. I replaced my TP Link (Archer C7 v5) which was running on DDWRT with a Netgear Nighthawk 7000P running on DDWRT and that has solved the issue.

Hi @Poseidon,

Thanks for the update here and for letting us know that it was networking related! I’m going to go ahead and mark this as the solution to the issue, but if anyone else who participated in this thread still has this issue occurring, please feel free to open a separate thread and we can take a closer look. Thanks!

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.